Jump to content
Welcome to our new Citrix community!

Certificate popup after starting an application

Uwe Meyer

Recommended Posts


i have configured Client Authentication with a user certificate.

I can login with the certificate and see my apps.

After start an application, a new popup appears from wfica32 with an certificate. When i clicked this cert, the application start.

How can i disable this second popup?


Netscaler 13.1 with latest build

Unified Gateway


I have found the following Note: https://support.citrix.com/article/CTX218917/avoid-client-certificate-prompt-smart-card-prompt-while-trying-to-launch-the-application-desktop-through-netscaler-gateway


But i use the Unified Gateway with a content Switch VS. Is it possible in this setup?





Link to comment
Share on other sites

Hi Uwe,





Try doing this only for your CS vServer instead of Gateway vServer - this should avoid the second popup. If that's no option (as you are publishing different further pages via CS) you can create the Dummy vServer like described in the CTX-KB (but remember to include your choosen port also in your Firewall NAT Policy, as your users will try to connect the HDX session via https://yourgatewayFQDN:DummyPort by design)




Link to comment
Share on other sites

  • 4 weeks later...

Thanks for the hint. That seems to have worked.


I have set the verification of a client certificate as the 1st factor (via NFactor Flows. When calling up the website, it now takes about 10 seconds until the login mask appears. During this time it is checked whether a certificate is available or not. The seems relatively long to me.

Do you have any other ideas?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...