Jump to content
Welcome to our new Citrix community!
  • 1

Odd keyboard layout issue in 1912 with Wyse thin clients v9 FW

Chris Gundry




TLDR: On a certain desktop, from a certain client type (Wyse v9 FW) keyboard is set to US, have @ symbol on Shift+2, but no " on @ key. Set it to UK, still no @ symbol on @ button, but " is on Shift+2 as expected. Various other keys are still strange, like get euro symbol on Shift+~ key. AFAIK that is not US or UK layout. Keyboard works fine in all other desktops and with other clients. All users on Wyse clients on this desktop are affected.


We have a very odd issue here. We have recently update Wyse Thin OS from v8 to latest v9. With this update comes a new Citrix receiver version, which supports the remote keyboard sync. We already identified this and handled it by configuring the Wyse policy to 'Specific keyboard'. The wyse detail around this is:

ThinOS allows VDA users to use a specific keyboard when logging in or reconnecting to VDA. Any keyboard layout change on the client side is not synchronized to the VDA session. Ensure that you select a specific keyboard on the ThinOS client before configuring the Admin policy tool or the Wyse Management Suite policy. If not selected, you must reboot the thin client to synchronize the specific keyboard into VDA.


The Wyse client specific keyboard is then set to UK layout, which is fine for us as we only use UK keyboards with these clients. Within the VDAs we have made no changes. In testing the users have had no further keyboard issues and keyboards are always UK now, great.


That is until today...  We have multiple published desktops, mainly just one, but occassionaly some users have access to a different one. Today we have had a user report that they don't get the UK keyboard in this other desktop and instead get the US keyboard. So the same user, on the same client, logging into the main desktop is fine. So this user has  two different desktops get's two different keyboard behaviours. There are no GPOs or Citrix policies applied to desktop 2 that are not applied to desktop 1.


More strange still, on the 2nd desktop, where they get US keyboard, they have @ symbol on Shift+2, but no " on @ key. Set it to UK, still no @ symbol on @ button, but " is on Shift+2 as expected. Various other keys are also strange, like get euro symbol on Shift+~ key. AFAIK that is not US or UK layout...


Has anyone got any suggestions on where I might look next as I am drawing a blank on this one!



Link to comment

3 answers to this question

Recommended Posts

  • 0

Hi Chris, i am facing the same problem with some of our ThinClients updated to 9.3x in combination with multi session 1912 CU3 VDAs.

Keyboard is set to dynamically sync to the session - and it is set correctly on the thin clients.

Sometime it works, sometime users do get their Session in US-Keyboard Layout (and not in German).

The most strange thing is, if you switch in the session to German Language and US Keyboard layout, they can write with german layout.

If you switch to German Layout in Windows, they get the US one.

Link to comment
  • 0

Hi Lukas

I am sorry to hear you are having the same/similar issue, although glad to hear we are not alone!

In our case it is only happening in this 2nd desktop, users in the main desktop appear to be OK. This is very odd to me and I am struggling to find any logic in the scnenario. But due to the user/desktop combination, it is fairly low impact for us, so luckily have no mad rush to fix it. Will update if we find anything!

Link to comment
  • 0

Hi Lukas


I wondered if you managed to find anything on this issue?


We managed to progress our issue slightly in that we were having issues typing @ key even when in UK layout. This turned out to be this issue, we implemented the top registry key and the issue is resolved.



We are still having issues with some users keyboards being set to US when logging in, but when changed to UK manually they now work correctly, where previously they would have issues with @ and euro symbol among others. We are still looking into why the keyboard sometimes gets set to US, it is very intermittent!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...