Jump to content
Welcome to our new Citrix community!
  • 0

User Pass through not working on Windows 10 VDI


Oje Alexis1709154468

Question

Hi Folks,

Been troubleshooting this for several weeks now and can't figure this out. Running LTSR 1912 CU4, Windows 10 21H2. Workspace client version 2204.1  We have published desktops and apps. SSO works for applications so that rules out an issue with ssonsvr.exe and browser settings. We used to be able to get passed through to VDI. At first it was a handful of users but now it's across the board. I've done the following:

  • Confirmed on GPO settings "Local username and password" and "Enable pass-through authentication"
  • I did notice Security Team was pushing registry  setting "FPromptUserForPassword". After disabling that it worked for half a day then broke again
  • Found registry setting "donotdisplaylastusername" was enabled. I disabled it and it started working again. THen a day later it broke
  • I built a plain vanilla Windows 10 VM from scratch and result was same. It worked for a bit then stopped
  • I ran RSOP on a few of them and see the Citrix settings from GPO taking effect. So it's not like it's being overwritten by a higher GPO. Even set the GPO to be enforced
  • SSO Config checker doesn't show any issues.... like I said pass through works for apps...... just not VDI sessions
  • Upgraded to CU5 on VDA.... no difference
  • Not seeing anything helpful in logs anywhere

 

Support hasn't been much help so I'm on my own here. Any suggestions are greatly appreciated.

 

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...