Jump to content
Welcome to our new Citrix community!
  • 0

Users connecting to an AWS-hosted XenApp causing VDA to become unregistered


Ken Z

Question

hi Everyone

 

have a strange one here.

 

Have a combination of the following

 

Citrix 2203 LTSR Farm running on Server 2019

StoreFront and 2 x delivery controllers in Azure

Multi-session VDA installed in our DataCenter

NetScaler installed in the same DataCenter. firmware version is 13.1 Build 24.38

NetScaler SNIP can route to both to both sets of multi-session VDAs, in DataCenter and AWS

1 x multi-session VDA installed in AWS

 

The AWS Server cannot see the Azure Delivery Controllers but can see the DataCenter ones, although the VDA only has the DataCenter servers in the registry key ListOfDDCs, and CTX338426 has been applied to the AWS Servers delivery group.

Additionally the StoreFront Servers and NetScaler only have the DataCenter STAs configured

Sites and Services is forcing the AWS Servers to talk to the correct DCs

PortQueryUI.exe reports no problems talking to the Active Directory domain from the AWS Server.

 

The problem i have is as follows

 

1) Internal users connecting to StoreFront directly can connect to both sets of multi-session VDA servers.

2) Users coming in through the NetScaler can connect to the XA Servers in the DataCenter but when they try connecting to the XA Servers in AWS this causes the VDA to unregister for a few minutes before it re-registers.

 

The following is logged in the Eventlog of the AWS Server

----

The Citrix Desktop Service's connection to the Citrix Desktop Delivery Controller Service was terminated. The Citrix Desktop Delivery Controller Service is running on server 'ddc01.domain.local'. 
 Check that there is no active firewall blocking the controller communicating with this machine. 
 Please refer to Citrix Knowledge Base article CTX117248 for further information. 
 Error details: 
Keep-alive request was rejected.

-----

Checking Google this has been happening on and off for about 10 years. CTX117248 is no longer available.

I've tried most things found on Google that I thought were relevant but this has made no difference.

I've even tried installing 1912 CU5 VDA onto the AWS server but this made no difference.

The issue is obviously something to do with the NetScaler trying to talk to the AWS Server but ther's nothing special in it's configuration. It's something I've done a million times.

Anyone seen anything similar in a similar environment?

 

Regards

 

Ken Z

Link to comment

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...