Jump to content
Welcome to our new Citrix community!
  • 0

XenServer 8.2 LTSR - "SR Operation cannot be performed because a device underlying the SR is in use"


Question

After the upgrade, our one HBA LUN decided to stop connecting.  I detached it and forgot it, now when I try to re-connect it, it comes up as format only, when I hit format it says "The SR operation cannot be performed because a device underlying the SR is in use by the server."  I've tried every article I could find trying to sever this connection, but no dice.  Any ideas?

Link to comment

4 answers to this question

Recommended Posts

  • 0

So I found that was also occurring, VDI not available.  I ended up blowing out the entire pool and rebuilding.   Thankfully it's QA and only had 10 VMs.  I did, however, find that going back to 7.1CU2 let me interact with the SR in question and reformat it.  I could detach and reattach fine.  Once I attempted this on an 8.2 build it would give that error.  I'm thinking drivers?  We use PURE for our HBA SAN, the upgrade blows out the multipath.conf file and replaces it with a generic.  I tried adding the recommended settings in the multipath.conf but i'm not sure if it needs to be baked in to the install or if you can update it in the OS and reboot?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...