Jump to content
Welcome to our new Citrix community!

2FA on ADC with user Principal Name Login Fail on Storefront


nlffel439

Recommended Posts

I am currently trying to set up 2FA authentication using the documentation from Carl Stalhood (https://www.carlstalhood.com/nfactor-authentication-for-netscaler-gateway-12/).

 

So far everything works (device registration and login to the gateway) but the strefront behind it has a problem (Request cannot be completed).

 

It reports

 

Quote

"CitrixAGBasic-Single Sign-On failed because the credentials could not be verified due to the following reason: Failed.

 

The credentials provided were:
User: testname@mail.com
Domain: 

 

Only difference from the documentation is that the login name is not the SAMAccountName but the UserPrincipleName (An e-mail address is used here ).

 

If I specify the domain via the session policy on the ADC , the following is displayed in the Storefront LOG 

 

Quote

 

CitrixAGBasic-Single Sign-On failed because the credentials could not be verified due to the following reason: Failed.

 

The specified credentials were:
User: testname
Domain: interndomain.local

The UPN is truncated starting with the "@". 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...