Jump to content
Welcome to our new Citrix community!

Saved v/s Running "Error in fetching the configuration"


Recommended Posts

I have ten different VPX HA pairs in our environment, but one (and only one) pair is unable to run the "Saved v/s Running" tool. We receive the pop up of "Error in fetching the configuration" whenever we try. 

 

Both VPXes can pull their saved and running configs without issue; I remember this environment working at one point, but I think we've gone through three different upgrades since with no change. This is on 12.1 64.16, which the majority of our other VPXes are on as well. 

 

Any suggestions?

SavedRunningError.PNG

Link to comment
Share on other sites

Hi Hailey,

 

That seems an odd error to get. Saved vs Running is basically getting the diff between the two. Have you tried doing this in CLI via the command:

 

diff ns config -outtype cli

 

Alternatively, you might find some additional information in the ns.log file located on /var/log on the appliance's disk.

 

To verify, I tried this on a 12.1 64.16 just now and it seems to work fine on both GUI and CLI for me, so I'm guessing it's something specific to your configuration.

 

Cheers,

G.

Link to comment
Share on other sites

  • 8 months later...

Thanks Gunther (sorry for the delayed response - didn't get the notification on the post). The CLI command works fine, that'll help for some of the smaller changes for sure.

 

From the ns.log, seems like it's succeeding just fine. We have upgraded this box to 13.1 since the original post. Going to send a ticket in, will report back what the fix ends up being.

 

 

Feb 21 06:40:12 <local0.info> IP_Address  02/21/2023:12:40:12 GMT hostname 0-PPE-0 : default CLI CMD_EXECUTED 175046619 0 :  User nsroot - Remote_ip 127.0.0.1 - Command "shell /netscaler/nsconfigaudit -sdiff" - Status "Success" 

Link to comment
Share on other sites

  • 3 weeks later...

Engineering was able to track it down - there was a timeout occurring with one of the libraries. 

 

If anyone else happens to come across it, this is where it was:

/netscaler/ns_gui/admin_ui/php/application/controllers/common/rapi_utils.php

Original line: static function get_ssh(&$response, $timeout = 10)

Updated line:  static function get_ssh(&$response, $timeout = 300)

Link to comment
Share on other sites

  • 1 month later...

We had the same issue with one of our ADCs. We had opened a support case and as a temporary solution we received a new rapi_utils.php file in which excactly this line was modified. In future releases this bug should be fixed. It was reported with the bug ID NSHELP-32752.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...