Jump to content
Welcome to our new Citrix community!
  • 1

Mouse pointer keeps disappearing on second monitor with Citrix Workspace App > 2203


mandue

Question

I have the following setup:

  • Laptop (ASUS Zenbook) with Windows 11, resolution 3840x2160
  • Additional HP monitor attached with HDMI, resolution 1920x1080
  • On the laptop, I connect to my workplace environment with the Citrix Workspace App
  • Citrix Workspace App has High-DPI setting deacivated (set to "no, use native resolution"). 

 

On the additional monitor, the mouse pointer keeps disappearing in various applications (e.g. Confluence, Outlook etc.). Sometimes it's flickering up quickly and disappears again. It's not possible to work this way. I didn't have this issue up to version 2203 of the Citrix Workspace App, but the issue persists with newer versions. I conclude that there must be a change since version 2203 causing this issue. 

 

Is there a way to get rid of this issue?

Link to comment

9 answers to this question

Recommended Posts

  • 0

Same issue here, but only with a specific notebook model (Lenovo T14) and Windows 11. The issue happened on multiple Levono T14 after a driver update. We didn't figure out which driver is exactly causing the issue at the moment. The issue only happens, when the cursor is in "Text Select" mode.

 

One workaround which helps for us at the moment is the following (on the VDA in the user session):

- Open Settings -> Devices -> Mouse

- Click on "Additional mouse options"

- Go to "Pointers", select "Text Select" and click on "Browse"

- Select "beam_i.cur" and confirm

 

 

Link to comment
  • 0
On 3/2/2023 at 6:05 PM, Moritz Frei said:

Are there any Updates or a real fix for this?

We have the same issue in our 2203 CU2 environment.

 

Only thing I've found is to change the cursor scheme from the Windows default to "Black" or another scheme, otherwise the cursor randomly disappears on Word documents, PDF applications or really anything else with a text selector tool. I find it hard to believe that an obvious issue reported in June 2022 before the CU2 was released update is still not fixed in March 2023, Citrix are really slipping these days...

Link to comment
  • 0

We've got this same issue with a handful of users. I don't know much about their local machines, but we've been rolling back our VDAs to fix another issue recently, from 2209, 2203.1, 2203.2, and now we're back on 2112. I know for sure we saw this on both 2203 and now 2112. The VDAs are running NVIDIA GRID GPUs on AWS. Cursor scheme doesn't appear to fix the issue for us. I don't think we've tried it on the local computers though. We have tried rolling back CWA to 2112 as well, to no avail.

Link to comment
  • 0

Thanks for your answers. What also helps some time is to install the new AMD Graphics driver. 
https://www.amd.com/en/support/kb/release-notes/rn-rad-win-23-4-1

 

But another user still has the problem with an intel cpu and integrated graphics and another one with amd cpu and nvidia grapics card.

 

Even though I cannot recreate the error on my test clients with intel cpu and nvidia graphics card, therefore its useless to create a Citrix case.

All of this is the config of the local client and not the remote pc where I am connected to.

Link to comment
  • 0
12 hours ago, Moritz Frei said:

Thanks for your answers. What also helps some time is to install the new AMD Graphics driver.

 

Our HP t640 ThinPro clients use AMD GPU's, but are updated to the latest ThinPro 8.0 OS w/SP4 and there is no way to separately upgrade the AMD driver for ThinPro Linux. So unless Citrix/HP formally recognises this issue with Workspace for Linux then we're pretty much out of luck and just waiting on some future update to hopefully resolve the issue

Link to comment
  • 0
On 5/31/2023 at 3:44 PM, Moritz Frei said:

We created the below registry on the VDA, and it resolved the issue:

Registry path: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Graphics

Registry name: UseDDAPIForIDD

Registry type: DWORD

Registry value: 1

 

This sadly does not work on our HP ThinPro machines with Workspace 2209 through to 2203 on WS2022, no change whatsoever to the cursor rendering

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...