Jump to content
Welcome to our new Citrix community!

Users Drop to Login after ~5Min without Timeout with Receiver for Web after Upgrade to 13.0 85.19.nc @ MDX5550


lschuma989

Recommended Posts

We see Users getting dropped to Login after Upgrade to 13.0 85.19 on a pair of MDX 5550.

This happens when trying to start new apps after about 5 Mins.

 

They got dropped to login immediately without any Timeout Warning.
We use a customized RfWebUI and SF-Auth.

 

I looked for an error on our SF-Servers for quite a time until i decided to reboot one of them.

After I disabled one of the SF Servers and tried to start a new app, the message about a required re-authentication appeared instead of a hard drop to login, so there is a difference.

aaad.debug shows nothing special, just new Login-Delegations to SF. They all look the same.

 

I can see that quite a bunch of users to try to authenticate multiple times, so there also might be an additional login loop issue (https://discussions.citrix.com/topic/416455-citrix-adc-130-8519-workspace-app-login-loop/). I could reproduce that, but there were no complaints about that yet. The drop to login does not happen on all sessions after 5min, but from my testing at least in 50% of the times. If a session somehow persists a 5min, everything stays fine.

 

Active ICA Connections stay open, no issue there. The users are only able to login via Gateway and use either Receiver for Web with app launch via local installed CWA/Receiver or HTML5-Receiver. There is no difference in Behaviour.

 

EPA is configured as well but shows no issues. It runs on every subsequent login as well. If the loop issue hits and there is a request for authentication before the app selections shows, EPA also runs again as if it were a new connection.

 

Timeouts on SF are configured to 12h including adjustments to ticket-times. We did not change that or any part of our ADC-Config before or during update.

There is a second gateway vserver configured on the appliance which shows the same issue (different target, also customized RfWebUI).

Link to comment
Share on other sites

This helped as a workaround for now:

 

On 6/8/2022 at 2:41 PM, Julian Jakob said:

Hi, I had also some logon loops after updating to 13.1 21.50

 

Setting a session timeout in a session profile which overwrites the default solved the issue. I think there is a bug in the default session timeout which is facing some loops in session lifetime. It could be the same here, too.

 

Regards

Julian

 

so 13.0 85.19 seems to have the same issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...