Jump to content
Welcome to our new Citrix community!

13.1 Upgrade Messages - how to force upgrade from GUI


Recommended Posts

Although I ran the nspepi command without errors, 13.1 still complained when I tried to upgrade the 13.0 to 13.1.
Is there a way to force the upgrade - the equivalent of a -Y using the GUI? 

Or would it be best to "unset cmp param -policytype" as I'd seen in another forum message? 
I'm unclear if that one command would handle all of these five "bind cmp global" lines
that the upgrade process is complaining about.

 

image.thumb.png.829e9b2807669e365c6f567240fcf17a.pngThe following configuration lines will get errors in 13.1 and both they and dependent configuration will be removed from the configuration:

bind cmp global ns_nocmp_xml_ie -priority 8700 -state DISABLED

bind cmp global ns_nocmp_mozilla_47 -priority 8800 -state DISABLED

bind cmp global ns_cmp_mscss -priority 8900 -state DISABLED

bind cmp global ns_cmp_msapp -priority 9000 -state DISABLED

bind cmp global ns_cmp_content_type -priority 10000 -state DISABLED

The nspepi upgrade tool can be useful in converting your configuration - see the documentation at <a target="_blank" href="https://docs.citrix.com/en-us/citrix-adc/current-release/appexpert/policies-and-expressions/introduction-to-policies-and-exp/converting-policy-expressions-nspepi-tool.html">https://docs.citrix.com/en-us/citrix-adc/current-release/appexpert/policies-and-expressions/introduction-to-policies-and-exp/converting-policy-expressions-nspepi-tool.html</a>. Use nspepi tool available at <a target="_blank" href="https://github.com/citrix/ADC-scripts/tree/master/nspepi">https://github.com/citrix/ADC-scripts/tree/master/nspepi</a> for the most complete and up-to-date version.

Installation cancelled; if you wish to force the installation use the -Y option.

image.png

Link to comment
Share on other sites

Just explicitly set compression to advanced engine:

set cmp parameter -policyType advanced

 

It will still take the value set cmp parameter -policyType advanced as valid, but there no longer is support for set cmp parameter - policyType basic.

Either omit the line completely OR omit this one parameter and keep the externalcache enabled (though I believe that is default anyway).

CMP is using advanced engine only on 13.1

  • Like 4
Link to comment
Share on other sites

  • 2 months later...

When you look at this in the GUI you should have a list of both classic compression policies and advanced compression policies. Which ones are in use are determined by the engine type for compression.  If you compare names, these should correspond to advanced engines.

 

The classic policies that are default will be replaced with the already existing advanced cmp policies; so these should be the defualt ones and will be ignored.

 

You can ignore them and proceed or explicitly remove them if it will let you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...