Jump to content
Welcome to our new Citrix community!
  • 0

Register a registry for Custome Virtual Channel Client dll, but not loaded


Suky Jung

Question

Hello...

I am developing custom virtual channel using virtual channel sdk for windows.

After the development of the server-client respectively, the dll does not load normally even if the client dll is run after registry registration (sdk guide).

I can use the example program vdmix, but the new client dlls developed using it are not applicable.

[My registry information]

Define My Custom Channel Name = "TestingControl"

Registry : HKEY_LOCAL_MACHINES\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\ICA 3.0

- VirtualDriverEx : Mix, TestingControl

Registry : HKEY_LOCAL_MACHINES\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\TestingControl

- DriverName : Unsupported/ DriverNameWin16 : Unsupported/ DriverNameWin32 TestingControl.dll

TestingControl.dll is developed based on given example client sources.

For 2 days, I would test but....this dll doesn't load normally. And there is no error message and VDI is well executed. just this dll is not loaded.

Help me...please.

 

PS. Using a sample program, the development is carried out after the test is carried out.

If I delete the vdmix source code, paste the developed source into the vdmix .c, build it, and test it, it will perform normally.

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...