Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Viewer key mapping mac -> windows


Ogar Shrek

Question

I have mac with two keyboard layouts

  • czech querty
  • u.s.

and I'm not able to find good configuration of keyboard layouts between my mac and windows as server.

when I type on my mac to mac notepad with czech layout I'm typing

Quote

<+ěščřžýáíé='

qwertyuiopú)

asdfghjklů§¨

\zxcvbnm,.-

and with shift

Quote

>1234567890%ˇ

QWERTYUIOP/(

ASDFGHJKL"!`

|ZXCVBNM?:_


if I type with same layout into windows notepad, then I'm typing

Quote

\]ěščřžýáíé)|

qwertzuiopú(

asdfghjklů§¨

¥yxcvbnm,./

and with shift

Quote

|1234567890%ˇ

QWERTZUIOP&*

ASDFGHJKL@!+

 YXCVBNM_>?


I tried many configurations and no one lead to same text in windows notepad. Situation is mainly confusing for special characters like =-_<>()/\|

for us it looks like this
on local

Quote

§1234567890-=

qwertyuiop[]

asdfghjkl;'\

`zxcvbnm,./

 

±!@#$%^&*()_+

QWERTYUIOP{}

ASDFGHJKL:"|

~ZXCVBNM<>?

on windows
 

Quote

§1234567890/)

qwertzuiop¾‘

asdfghjkl<|¥

+yxcvbnm,.&

 

±!ä\$%`^}*(?]

QWERTZUIOP½’

ASDFGHJKL>@

»YXCVBNM\|_

mainly special characters are somewhere else then they normaly are.

What can I do to correct key mapping?

Link to comment

3 answers to this question

Recommended Posts

  • 0

Hi Ogar,
This is the keyboard layout that I get after installing Czech - QWERTY layout on my mac which is marginally different from the layout described in your query.

609528891_Screenshot2022-05-23at9_10_49AM.thumb.png.9c918cd9f9822c245898596899d153cd.png

 

Can you specify if you are using a physical Czech keyboard?

 

Also, can you specify the version and keyboard settings of the workspace app you are using?

For version, please open the Citrix Workspace App -> Go to top menu, click Citrix Workspace -> About Citrix Workspace

For keyboard settings, open the Citrix Workspace App -> Go to top menu, click Citrix Workspace -> Preferences -> Keyboard ( Click on ">>" if keyboard setting is not visible initially).
2083346264_Screenshot2022-05-23at9_25_09AM.thumb.png.3ee3b599f56bc641a828b4d9e715193c.png

Link to comment
  • 0

Hi Ogar,

 

It might help to enable Keyboard Layout Sync. It allows for VDA keyboard layout to sync with client keyboard layout. It should be enabled both on the VDA side and client side. It can be enabled on the client side by checking the option "Use local keyboard layout, rather than remote server layout".

Please refer to this article for more information regarding keyboard layout sync and setting it up.

https://www.citrix.com/blogs/2020/04/22/citrix-virtual-apps-and-desktops-keyboard-and-ime-configurations/

 

Regards,

Noorul

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...