Jump to content
Welcome to our new Citrix community!
  • 0

Workspace app does not open RDP on openSUSE 15.3


Pavel Dmitriev

Question

I have installed Citrix Workspace app Version 22.5.0.16. on openSUSE Leap 15.3 using rpm package and made initial setup for the account.

I see the list of my applications including connection to Windows Desktop.

However, when I click to open any application or Windows Desktop there is a spinning icon appears for a short time and nothing happens afterwards. Log output for this case is in fail.log attached file in verbose mode.

On the other hand, when I open Citrix Workspace in web-browser and then click on any application, which then redirects to desktop app via xdg-open, the application opens successfully (log output in verbose mode for this case is in success.log).

Unfortunately it is hard to identify from logs where the real problem is. Maybe somebody had similar problem and somehow solved it?

 

There is also workspacecheck.sh command output, if it anyhow helps (See: workspacecheck.txt)

 

There are log files for succeeded run:  success.log and failed run: fail.log.

Link to comment

2 answers to this question

Recommended Posts

  • 0
18 hours ago, Christian Britz said:

Your workspacecheck looks OK. I have no problems with this release on Debian. Did previous versions work for your or are you trying the linux client for the first time? Are you using X11 or Wayland? I had problems with Wayland, although I was able to connect.

 

I've tired multiple versions, and only one super old (don't remember the version) worked for me, but that version missed a lot of feature like "keyboard layout sync" and "drives map". At least 3-4 previous version didn't work for me as well.

I am using X11.

Edited by Pavel Dmitriev
Forgot to mention X11
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...