Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Upgrade From 7.14 -> ?


David Faktor

Question

Good Day,

 

So i have an Farm on 7.14 2012 R2 and want to move to 2019 / 2022 but what Versions will work due to the Licenses that i have as i saw some where that you cannot install 2203 on 2022 on an VM in Azure or AWS.

 

Please correct me or guide me on the correct version to use.

 

Thanks
David

Link to comment

8 answers to this question

Recommended Posts

  • 0

Are you asking about Azure/AWS Host Connections in Citrix Studio? If so, then CVAD 1912 is the last version to support it using on-prem licenses. CVAD 2203 supports if you have Cloud licenses with Hybrid Rights.

 

Or are you asking how to in-place upgrade your Citrix database to CVAD 2203? You'll need to do multiple updates:

  • Upgrade existing to 1912.
  • Add Windows 2019 servers with CVAD 1912 to existing farm. 
  • Remove old Windows 2012 R2 servers.
  • Upgrade Windows 2019 servers to CVAD 2203.
  • Add Windows 2022 servers with CVAD 2203. 
  • Remove Windows 2019 servers.
Link to comment
  • 0

Hi Carl,

 

Sorry yes i have an Azure Farm right now on 2012 R2 and i need to upgrade it / rebuild it.

 

My Plan is to build out a new farm and Windows Server xxx & Citrix Version xxx . Just need to know what OS and Version is should use.

 

Thanks

Link to comment
  • 0

Do you have any Hosting Connections in Citrix Studio (for MCS or Power Management) that point to Azure? If no, then you don't need any special licensing. If yes, then you need Citrix Cloud DaaS with hybrid rights licenses.

 

CVAD 1912 is the last version to support Azure Hosting Connections using only on-prem licenses. CVAD 2203 and newer requires Citrix Cloud DaaS with hybrid rights for Hosting Connections to Azure.

Link to comment
  • 0

I have an very Basic Setup and i am not an pro at all very noob :). I just have 3 servers in Azure and team uses it to connect to services for the clients. 

 

So i think i will stick to 1912 LTSR and i take it the OS is 2019 as the Max OS correct.

 

Thanks

Link to comment
  • 0

Thanks Carl, So i can use the latest 2203 BUT is the Windows OS 2019 or 2022 that i need to use. 

 

As i know that in our environment someone tested out 2203 on 2022 and got "Server Name was rejected because the VDA is a public cloud vm ....)

 

Thanks for the info and help here.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...