Jump to content
Welcome to our new Citrix community!
  • 0

New AppV applications do not launch with error "Cannot start unknown application"


Question

New AppV packages added on a Citrix 2203 LTSR VDA do not launch with an error message "Start not possible unknown application":

image.png.c9b07e3181e1c804203fd4640de45f92.png

Any other not reconfigured packages launches without problems. Only edited or new published AppV packages cannot be started.

 

In 19.12 CU4 it worked without trouble. Is it a known issue in 2203 ?

 

Server VDA: 2203 LTSR / Server 2019 Build 1809

 

For more information how I publish the AppV packages in our environment look at my posting here:

https://discussions.citrix.com/topic/398158-start-app-v-packages-via-receiver-on-same-machine-as-logged-on-server/

 

 

Link to comment

6 answers to this question

Recommended Posts

  • 0

Solved by Citrix with these steps:

 

1.

All applications are detected with the Source: Master Image and not Applibrary App-V. This is because of the CommandLineExecutable. So change CommandLineExecutable from full path to shortlink:

 

$ Get-BrokerApplication | Where-Object { $_.CommandLineExecutable -like "*CtxAppVLauncher.exe*"} | Set-BrokerApplication -CommandLineExecutable CtxAppVLauncher.exe

 

2. 

Closing Citrix Studio and open again.

Start the automatic Site upgrade

 

3. 

Verifying that all AppV packages now on Application Library instead of Master-Image:
image.thumb.png.c0c6da3f597916b359e3f80856061867.png

 

After that, new packages can be added successfully and run via shortcut from startmenu.

 

To find Uid for commandline arguments using

 

$ Get-BrokerApplication -ApplicationName "Filezilla"


CommandLineArguments             : 13358080-7d82-048f-3aae-3d140491fde2
CommandLineExecutable            : CtxAppVLauncher.exe

image.thumb.png.1c74c25d7f5ddd6b195bc42de28f8787.png

 

Big thanx to @grzegorz iskra !!!

  • Like 1
Link to comment
  • 0

After deeper investigating I've found, that new package-IDs were not

synchronized to the VDAs registry-key (see picture one).


image.thumb.png.be0435fb9f4ffc6f9c87516da356d49f.png

 

Comparing a working AppV package (IfanView) with the new not running

package (VIM Editor) showes only one difference:

 

ConfigurationSlotUids is set to 4 on working AppV package, and none in

the not working package (see picture two).

 

image.thumb.png.a12156aece7eeef38e8095d0107e19f7.png

 

Also deleting the whole regkey and restarting Citrix Desktop Service,

only the existing packages were synchronized.

Link to comment
  • 0

HI Jens,

The issue is with application command line executable.

 

Previously we used 1 configuration / 1 application. In recent releases we use: 1 configuration / 1 Desktop group.

Because the command line contains the full path  (by default it shoudl be just the ctxappvlauncher.exe -> this is not considered as single mode application. Because of that the app is not added to the new configuration.

 

 

Link to comment
  • 0

Hello Grzegorz,

 

thank you for your reply and detailed solution. But if I add the application without changing the executable, the app still not synced to HKLM:\Software\policies\Citrix\AppLibrary [ApplicatioStartDetails].


In Citrix Sudio the App appears as:

image.thumb.png.43f7f554f66fdd720401de1849881945.png

 

AppV publishing:
image.thumb.png.f1e09248e8a278d77ecb43273974fdb7.png

 

We’ve used following command-line to change the executable:

$ Get-BrokerApplication -CommandLineExecutable ctxAppVLauncher.exe | Set-BrokerApplication -CommandLineExecutable "ctxAppVLauncher.exe"

 

But it's still not synced.

 

We need to start the app via shortcuts deployed via GPO that looks like that:
image.png.24addc5ee49d43663b8d9091df3d47d8.png

But I also don't know how to find the UID of the package.

 

So for my understandings, what are the steps to deploy the appV package to run it via shortcut from startmenu ?

 

 

Link to comment
  • 0

Solved by Citrix with these steps:

 

1.

All applications are detected with the Source: Master Image and not Applibrary App-V. This is because of the CommandLineExecutable. So change CommandLineExecutable from full path to shortlink:

 

$ Get-BrokerApplication | Where-Object { $_.CommandLineExecutable -like "*CtxAppVLauncher.exe*"} | Set-BrokerApplication -CommandLineExecutable CtxAppVLauncher.exe

 

2. 

Closing Citrix Studio and open again.

Start the automatic Site upgrade

 

3. 

Verifying that all AppV packages now on Application Library instead of Master-Image:
image.thumb.png.c0c6da3f597916b359e3f80856061867.png

 

After that, new packages can be added successfully and run via shortcut from startmenu.

 

To find Uid for commandline arguments using

 

$ Get-BrokerApplication -ApplicationName "Filezilla"


CommandLineArguments             : 13358080-7d82-048f-3aae-3d140491fde2
CommandLineExecutable            : CtxAppVLauncher.exe

image.thumb.png.1c74c25d7f5ddd6b195bc42de28f8787.png

 

Big thanx to @grzegorz iskra !!!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...