Jump to content
Welcome to our new Citrix community!
  • 0

Cannot connect Workspace to Storefront


Mike Maggio1709162854

Question

We are trying to connect Workspace to our Storefront enviornment and are using the same URL that we use for our web clients. The web browsers work fine but Workspace keeps giving me this error:

 

This store doesn't exist. Please retry or contact support.

 

I've checked the beacon configuration and we have the internal beacon set for a nonexistant URL. I"ve also tried removing that but to no avail.

 

Any ideas?

 

Mike Maggio

Link to comment

8 answers to this question

Recommended Posts

  • 0
On 4/20/2022 at 9:51 PM, Mike Maggio1709162854 said:

We are trying to connect Workspace to our Storefront enviornment and are using the same URL that we use for our web clients. The web browsers work fine but Workspace keeps giving me this error:

 

This store doesn't exist. Please retry or contact support.

 

I've checked the beacon configuration and we have the internal beacon set for a nonexistant URL. I"ve also tried removing that but to no avail.

 

Any ideas?

 

Mike Maggio

 

Hi Mike,

 

Any update on this matter? Do you find the fix resolution on this issue?

 

 

- Zulhadi-

Link to comment
  • 0

HI Zulhadi


Yes, we finally got it fixed. The issue was that we were using a self-signed cert on the storefront site.  As per the tech, " An untrusted connection will cause the Workspace Agent to deny connection, so the certificate either needs to be signed by a trusted CA (internal or public) or the self-signed cert would have to be distributed to the endpoints in the Trusted People container."

 

Hope this solves your issue.

 

Mike

 

Link to comment
  • 0
15 hours ago, Mike Maggio1709162854 said:

HI Zulhadi


Yes, we finally got it fixed. The issue was that we were using a self-signed cert on the storefront site.  As per the tech, " An untrusted connection will cause the Workspace Agent to deny connection, so the certificate either needs to be signed by a trusted CA (internal or public) or the self-signed cert would have to be distributed to the endpoints in the Trusted People container."

 

Hope this solves your issue.

 

Mike

 

 

Owh.. ok...

 

my issue on ground, this only one user that accessing via workspace received this error. Other users in the environment is all good without having any issue.

 

For now, I asked him to try accessing the Gateway using the browser instead using the Citrix Workspace App. Just to try it first.

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...