Jump to content
Welcome to our new Citrix community!
  • 0

Unstable connection with Workspace for MAC through Netscaler Gateway


Rahul Sukumar

Question

Netscaler 12.1

RADIUS auth to NPS server

Pass through auth to Storefront 2203

 

Our environment was very stable for all OS Workspace apps (Windows, Android, iOS, and MacOS) until I upgraded the SSL cert bound to the Gateway vServer. After that, MacOS clients are unable to connect to published apps or desktops reliably. All other Workspace OS versions still work perfectly fine.

 

I've tried everything I can think of including using a brand new Macbook Air and fresh install of Workspace. I can add the store to Workspace by using the FQDN of the Netscaler but initial authentication pop up takes 30+ seconds. Authentication is successful but then the Workspace app just shows a circling icon for 30+ more seconds until published apps appear. I can then start apps just fine and use them. But then, after logging off all apps and closing Workspace, I cannot start Workspace again to log on through the Netscaler. It gives me an error (attached). 

 

I've tried multiple versions of Workspace and all exhibit the same problem. When trying to analyze the Workspace logs, it appears that it is trying to connect to the internal URL of Storefront. I checked the beacons and everything looks fine (plus, the same configuration works on all other OSs, including Receiver for Web). In fact, I can use Safari on the same Mac to connect to Receiver for Web URL and can connect with no problems, which to me eliminates the possibility of a certificate issue on the Gateway.

 

Any ideas? Thanks!

MacOs Error.jpg

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...