Jump to content
Welcome to our new Citrix community!
  • 0

cannot launch apps from workspace 2203 on Mac operating Monterey 12.2.1


Question

Citrix Workspace app Version: 22.03.0.27 (2203)

MacOS Monterey 12.2.1

Can log into the workspace, see all the apps I should inside, but -

When clicking on app inside the Citrix Workspace, error appears with only a Quit option:

"You have not chosen to trust "DigiCert TLS RSA SHA256 2020 CA1", the issuer of the server's security certificate. Contact your help desk for assistance."

 

I don't remember not trusting anything. Is this a version-version mismatch or an issue with my employer's setup? till it's fixed I'm unable to access Epic for work ?

Is this something expected to correct soon? uninstall/reinstall doesn't fix it.

 

EDITED to add web instructions for accessing padlock and downloading .crt certificate, adding it to the system successfully resolved the issue.

Link to comment

3 answers to this question

Recommended Posts

  • 0
20 hours ago, Hailong Li said:

It seems you do not install root cert on mac, not related to TLS

Could you check if you have installed the correct root certificate?
Normally you can find the link and install the root certificate from the certificate's description.

Thanks

I have done all process same as before, like installation of Root Certificate etc. But this version of Citrix is not restarting with remote Windows server. While when I access remote REHL-7 Linux server then it works fine.

 

For me still Citrix version 2101 is useful/working. Not sure when Citrix newer version will be working, I'm afraid when Citrix 2101 will not be working with upgraded server version of my organisation then my Macbook Air M1 2020 will be useless for me.

Link to comment
  • 0

I got a very specific "certificate name" which was:  "Digicert GLOBAL G2 TLS RSA SHA256 2020 CA1". I checked in the keys and it was not there, so it looks was obvious, but the message makes the confusion when states "you have not chosen". The message could be more specific like:  "you don't have the xxxxxxx certificate installed". 
Anyway, I just copied the entire name that was being complained and google for it. 

Found it here:
https://www.tbs-certificates.co.uk/FAQ/en/DigiCertGlobalG2TLSRSASHA2562020CA1.html

more likely here: https://digicert.tbs-certificats.com/DigiCertGlobalG2TLSRSASHA2562020CA1.crt 

After download it and open it with keys, the issue was gone and the viewer worked like a charm. 

Hope that helps ! 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...