Jump to content
Welcome to our new Citrix community!

13.1-17.42 issues?


Kyle Peterson

Recommended Posts

Is the issue with loading storefront behind the gateway and is the gateway working?

Or is the issue just with storefront loadbalancing and no gateway before hand?

Which version of storefront AND are you upgrading an ha pair or not?

 

If the gateway is involved,

In order for the gateway to attempt to even connect to storefront it sends a monitoring probe to see if storefront is alive; if not, it won't even attempt the storefront connection.

You can see the result of this probe in the nslog output.  If the probe worked on one build and not the other it might still be a bug, but you can see what the possible error is related to.

nslog output:

shell

cd /var/nslog

nconmsg -K newnslog -d event

nconmsg -K newnslog -d consmsg

 

I believe the message shows in event with the probe name being internal_<storefront fqdn name> based on the storefront name in your session policy.

Possibly failures could be lack of SNIP, name to ip resoultion failure, or firewall blocking ports.  

 

Do you still have any classic policies in use?  As there may be a difference between policies accepted on the earlier build vs later? 

 

 

Otherwise, I would do a trace and log it with support if there are no otehr differences than build number.

Link to comment
Share on other sites

Its hard to explain but I can login to the gateway webpage fine but then I just see some text that says something like "select one of the following" 

 

And at the same time my windows cursor changes to the spinning circle like chrome is trying to do something.

Not a big deal, just was curious if anyone else has ran the update yet and saw the same thing, its pretty recent.

Link to comment
Share on other sites

If the issue is after Gateway login, does the web browser still have the Gateway path:  /vpn/index.htm or /logonpoint/<theme name>

or does it show the storefront path like /Citrix/<storeNameWeb>

 

If the former, the issue is something on the gateway vpn vserver as it is not completing the authentication/authorization or portal theme load. And portal them issues after upgrades are common, so maybe revert back to default theme or see if there is a difference.  Or it is the probe issue I mentioned above.  

In either case, it works before upgrade and doesn't work afterwards, probably means you need a support case.  But the portal them and syslog/nslog events may identify if something else is going on.

 

If the /citrix/<storename> is in the path and failing to load, the gateway completed its transactions and the issue is in the communication to storefront. But why, I don't know.

 

So hopefully someone else can say if they've seen this. But that might give you a few aspects to check.

Link to comment
Share on other sites

  • 2 months later...

Tried upgrading again to the latest version and had the same issue, took a quick screen shot before reverting. All looks good but once I log in all I see is in the pic.

Ill just build a new netscaler vm and see what happens, this one was built just within the last year or so.

netscaler gateway.PNG

Link to comment
Share on other sites

You are 100% correct, I do have HSTS checked on the vserver, I really only have it enabled to get a A+ on ssllabs. Curious if you know why this is happening now? Thanks! 675307609_netscalerv2.thumb.PNG.33f84291afe9c00ef572e8e78363dfb7.PNG

 

Quick edit I found this post https://discussions.citrix.com/topic/415276-access-gateway-broken-after-130-8410-or-8411/page/3/

 

Pretty much have to disable hsts, good enough. Thanks

Edited by Kyle Peterson
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...