Jump to content
Welcome to our new Citrix community!
  • 0

Citrix session ends unexpectedly with Workspace App 2022.2


Thomas Schlaumlppi

Question

If I start a published application, the session can be created but disconnect after a few moments.

 

 

/var/log/citrix/ICAClient.log says:

2022-02-22 09:41:43.594 [TW] <P10699> citrix-wfica: <Flush  
2022-02-22 09:41:43.594 [TW] <P10699> citrix-wfica: <FlushFrame  
2022-02-22 09:41:43.595 [TW] <P10699> citrix-wfica: <Tw2CmdEndOfFrame  
2022-02-22 09:41:43.595 [TD] <P10699> citrix-wfica: Error reading data. try again, failure: 11  
2022-02-22 09:41:43.607 [WD] <P10699> citrix-wfica: OutBufReserve: bc = 2048  
2022-02-22 09:41:43.607 [WD] <P10699> citrix-wfica: 2048 bytes, channel 64
 
2022-02-22 09:41:43.607 [WD] <P10699> citrix-wfica: OutBufReserve: bc = 2048 GO GO GO  
2022-02-22 09:41:43.607 [WD] <P10699> citrix-wfica: OutBufAppend 3 bytes, WB=0, WR=0, WL=800  
2022-02-22 09:41:43.607 [WD] <P10699> citrix-wfica: OutBufAppend 6 bytes, WB=0, WR=0, WL=800  
2022-02-22 09:41:43.607 [WD] <P10699> citrix-wfica: OutBufWrite  
2022-02-22 09:41:43.608 [WD] <P10699> citrix-wfica: Connection pipeline = 0 for stream 0, Original backlog = 0  
2022-02-22 09:41:43.608 [WD] <P10699> citrix-wfica: OutBufAlloc: 55d753ac5f00, mem 55d753ac5f30  
2022-02-22 09:41:43.608 [WD] <P10699> citrix-wfica: ----------------- SND 11 (1064) ------------------  
2022-02-22 09:41:43.608 [WD] <P10699> citrix-wfica: Packet length = 11, max = 1411, orig max = 1453  
2022-02-22 09:41:43.608 [WD] <P10699> citrix-wfica: Send 1 packets on stream 0  
2022-02-22 09:41:43.608 [WD] <P10699> citrix-wfica: Sending packet on stream 0, of length 12  
2022-02-22 09:41:43.608 [PD] <P10699> citrix-wfica: CGPGetCGPOutputBuffer: 0x53bfdb68 ==============  
2022-02-22 09:41:43.608 [PD] <P10699> citrix-wfica: CGPsend: sending 15 bytes *********** 0x53ac5f30  
2022-02-22 09:41:43.608 [PD] <P10699> citrix-wfica: TCP Proxy Service: TcpProxyChannelSendData entered.
 
2022-02-22 09:41:43.608 [PD] <P10699> citrix-wfica: CGPCore: CgpWriteToChannel entered.
 
2022-02-22 09:41:43.608 [PD] <P10699> citrix-wfica: CGPCore: Channel 0: Writing out a CGP_DATA_REALTIME message with 0 ACKs.
 
2022-02-22 09:41:43.608 [TD] <P10699> citrix-wfica: doEncryptData inbuffersize: 17  
2022-02-22 09:41:43.608 [TD] <P10699> citrix-wfica: SSLPutDataFn inbuffersize: 46  
2022-02-22 09:41:43.608 [PD] <P10699> citrix-wfica: CGPCore: CgpWriteToChannel exiting with status: 0x2.
 
2022-02-22 09:41:43.608 [PD] <P10699> citrix-wfica: TCP Proxy Service: TcpProxyChannelSendData exiting with status 0x2.
 
2022-02-22 09:41:43.608 [PD] <P10699> citrix-wfica: CGPsend: sent 15 bytes *********** 0x53ac5f30  
2022-02-22 09:41:43.608 [TD] <P10699> citrix-wfica: TcpSend: stream 0, ipLayer 1373137888, bc=15, bs=15  
2022-02-22 09:41:43.608 [WD] <P10699> citrix-wfica: OutBufFree: 55d753ac5f00, mem 55d753ac5f30  
2022-02-22 09:41:43.608 [FRAME] <P10699> citrix-wfica: PdRFrame: DeviceWrite, bc 15, Status=0x0

 

Link to comment

1 answer to this question

Recommended Posts

  • 1

Problem solved!

 

Reason:

I've started the application using Citrix Gateway opened in Chromium, which was running in a sandbox (snap). The ica file was handed over using xdg-desktop portals (I assume), and the wfica process was successfully created.

Somehow, xdg-desktop-portal send a kill command to the wfica process and the session wanished, probably due missing run-as-background permissions.

 

Solution: using a browser installed using a .deb.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...