Jump to content
Welcome to our new Citrix community!
  • 0

Stucking Logons with WEM error


Question

We've got randomly stucking logons (just 2 the week) with the following eventlog entry:

Event ID 0 - WEM Agent Service

Forcing stop of running logon task for User : 

 

UserName : domain\user

Session ID : 10

 

Logoff the session via Director and the user can logon again.

 

We've installed the hotfix from CTX340125 for 19.12 CU4 and CTX340175 for 2112.

 

Our environment:
Server 2019

WEM 2112

Citrix 19.12 CU4 and 2112

Publiched Desktop (no published apps)

 

 

Link to comment

2 answers to this question

Recommended Posts

  • 0

It's a little bit difficult to reproduce the issue. After logoff the session, the logfile was deleted by Citrix UPM. What I've seen is, that in the eventlog the following message 
comes up every 10 minutes:

 

Broker-Side:

System.NotImplementedException: The method or operation is not implemented.
   at Citrix.Wem.Common.Data.Broker.Sqlite.BrokerCacheDataProvider.GetExecutableTaskSettings(Int64 siteId)
   at Norskale.Broker.Agent.AgentBrokerService.GetExecutableTaskSettings()

 

Agent-Side:

An error occurred while retrieving executable task data!
  System.ServiceModel.FaultException`1[Norskale.Common.Data.Faults.DataReaderFault]: The creator of this fault did not specify a Reason. (Error is equal Norskale.Common.Data.Faults.DataReaderFault).

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...