Jump to content
Welcome to our new Citrix community!
  • 0

Re-creating machine catalogs in Citrix Cloud necessary to update?


Stephen D. Holder

Question

Greetings,

 

I’m working with a client who is running Citrix Cloud (as control pane) and all workloads, etc,  on-prem.

 

I'm trying to update an existing machine catalog using Citrix Cloud. The catalog is Windows 10 , VDA version 2106, single session, random desktop experience.

 

I’ve spent 7 snapshots trying to add simple changes to the master image and updating it accordingly…but the master catalog but it keeps ‘updating’ to the original instance – meaning none of the 7 snapshots I took or selected in the Citrix Cloud studio took (or persists )  once the update completes.

 

I’ve found the only true way to update the machine catalog is to delete the existing catalog and create an entirely new one. I don’t remember this ever happening before.

 

Is this the expected behavior,.... to delete and recreate a catalog each time you want to update a machine collection?

Link to comment

3 answers to this question

Recommended Posts

  • 0

Hello Stephen,

 

that's definitely not the exptected behavior. Recreating a new machine catalog is the last "emergency task" if nothing else is working ? 

 

Citrix Cloud is supporting both updating random linked clones and static full copy clones (Cloud-Only feature), too. Are you able to check and verify your hosting connection to your OnPrem Hypervisors? Are you seeing disk copy tasks in your hypervisor logs?

 

Best Regards

Julian

Link to comment
  • 0

Hi @Julian Jakob

 

I am able to confirm that Citrix Cloud has connections to the hypervisor. I for sure see and select the proper snapshot each time in Citrix Cloud.. but no good.. it never updates the machine with the newer changes.  If I hurry back to the hypervisor I can see some work being done -- creating snapshot.. etc.. but that's about it.

 

Where can I find the logs and what exactly should I be looking for?

 

Link to comment
  • 0
On 2/9/2022 at 12:53 PM, Stephen D. Holder said:

Hi @Julian Jakob

 

I am able to confirm that Citrix Cloud has connections to the hypervisor. I for sure see and select the proper snapshot each time in Citrix Cloud.. but no good.. it never updates the machine with the newer changes.  If I hurry back to the hypervisor I can see some work being done -- creating snapshot.. etc.. but that's about it.

 

Where can I find the logs and what exactly should I be looking for?

 

 

 

We have a dedicated Catalog and we want to create another pooled catalog. So, basically we have to go and take a snapshot in Azure and then we will have to remote into the image and update it it? Is that the way it works?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...