Jump to content
Welcome to our new Citrix community!

Error when trying to open apps through gateway.


Recommended Posts

Running netscaler 13 and trying to setup external access through netscaler to storefront.  I currently have internal connections to storefront working without an issue but for some reason I'm having issues with opening them through citrix gateway.  I'm able to login and authenticate and all of my published app display but once I try to open an app I get an error "Unable to connect to the server.  Contact your systems administrator with the following error.  Socket is not connected (Socket error 10057).

 

I"m don't see anything the logs on storefront and I even enabled verbose logging and unable to get any errors.  Has anyone see this issue before?  all the fixes found online have not resulted in any sucess.  Any help or suggestion to point me in the right direction would be awesome.  Thank you 

Link to comment
Share on other sites

I would take a look at this one - https://support.citrix.com/article/CTX227054

 

Which details the full integration between Gateway, Storefront etc. grab a packet capture on the Gateway, and use the article to find out at what stage it's failing for you, 

 

As you've stated above, all fixes found online have not succeeded, and app launch failure can be because of one or many different root causes, 

 

nstrace, and follow the flow in wireshark is probably the easiest way to get to the bottom of this, 

 

https://docs.citrix.com/en-us/citrix-adc/current-release/system/troubleshooting-citrix-adc/how-to-record-a-packet-trace-on-citrix-adc.html some good instructions here on capturing the trace

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...