Jump to content
Welcome to our new Citrix community!
  • 1

Citrix Workspace: Connection interupted on Mac OS Montery 12.1


Christophe Van Calster

Question

Hello, 

 

I'm having serious issues with my Citrix connection on Mac OS Montery 12.1 

Sessions disconnect repeatedly, sometimes it's working for a couple of hours and then it disconnects again. 

 

Sometimes a session can be active for a while without using but if you start using it it disconnects after a couple of seconds. 

A lot of times it's just disconnecting while working (20+ times a day).  

 

I tried downgrading to previous workspaces - even tried the beta but that didn't resolve my issues. 

I did a complete clean install of my Mac and Citrix workspace and the problem stays the same. 

 

When I open a Citrix session on the same mac in a Linux environment (VM Ware) then there is no issue and everything works fine...

Another collegae wit ah Mac on Montery  faces the same issues. 

 

When we connect local (VPN) we also dont't have any issues. 

 

Can this be a Netscaler issue an Apple or a Citrix Workspace issue?

 

It's really slowing us down.

 

Any help is appreciated. 

 

 

 

 

 

 

 


 

Link to comment

9 answers to this question

Recommended Posts

  • 1

BREAKING NEWS everyone on the specific issue of MAC (and possible other non-windows) CWA clients getting randomly disconnected unexpectedly with the "connection interrupted" pop-up message: After months of troubleshooting with both the Netscaler engineering team and VDA engineering team I just finished testing a new special build with a private fix in it that seems to solve the problem completely. After all this troubleshooting I have have identified that:

 

-The problem only happens when the connection is happening through a Netscaler Gateway. So you won't see the problem when connected through a third party VPN or internal network.

-The CWA client must be a MAC (or potentially other non-windows). The issue will not happen with a Windows CWA

-This particular problem was introduced as early as of VDA agent 2112 and is present in all later editions.

-The problem only happens when inside the Citrix session from the MAC a client-redirected device or drive is being accessed or used in any way. The easiest way to force and bring out the problem is therefore to start a continuous copy of a very large file inside the Citrix session on the from the MAC client machine towards the VDA or remote network inside the VDA. Then start clicking with your mouse on the empty desktop until the problem happens. Using this way I can consistently bring out the problem within 5-30 seconds.

 

Suspected Root cause: It's still under investigation but if this is correct it seems to be a problem introduced by a change in the winstation driver wdica.sys

Solution: obtain a new/old version of the driver through a private fix (you can refer to my Citrix CASE 81283528) and replace the current faulty version with it. Alternatively wait for a future public fix version to appear.

 

I hope this makes your day or at least helps you ! Feel free to use the upvote button

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...