Jump to content
Welcome to our new Citrix community!
  • 0

Ubuntu 21.10 LTS Arm Pi4 Missing Dependancies


Drew Me

Question

Hello,

 

I have been trying to install Citrix Workspace on my Pi4 (4GB) model for some time.

 

I am running with the following configuration:

Ubuntu 21.10

Linux version:

5.13.0-1015-raspi (buildd@bos02-arm64-075)

 

I have downloaded the latest 'installation package' from Citrix website:
(https://www.citrix.com/downloads/workspace-app/linux/workspace-app-for-linux-latest.html)

 

Downloaded the latest version for ARM:

Citrix Workspace app for Linux (ARM HF)

 

When I try just 'double clicking' the DEB file, it says I have unmet dependencies.

- Although the Software installer never LISTS these dependencies.

 

After a few trials in terminal, I was able to find a list of ALL the things it was missing.  All of which were or are uninstallable:

=====

~sudo apt install ./icaclient_21.12.0.18_armhf.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'icaclient:armhf' instead of './icaclient_21.12.0.18_armhf.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

 

The following packages have unmet dependencies:
 icaclient:armhf : Depends: libc6:armhf (>= 2.15-0) but it is not installable
                   Depends: libice6:armhf (>= 1:1.0.0) but it is not installable
                   Depends: libgtk2.0-0:armhf (>= 2.12.0) but it is not installable
                   Depends: libsm6:armhf but it is not installable
                   Depends: libx11-6:armhf but it is not installable
                   Depends: libxext6:armhf but it is not installable
                   Depends: libxmu6:armhf but it is not installable
                   Depends: libxpm4:armhf but it is not installable
                   Depends: libasound2:armhf but it is not installable
                   Depends: libstdc++6:armhf but it is not installable
                   Depends: libidn11:armhf but it is not installable
                   Depends: zlib1g:armhf but it is not installable
                   Recommends: libglib2.0-0:armhf (>= 2.12.0) but it is not installable
                   Recommends: libgstreamer-plugins-base0.10-0:armhf (>= 0.10.15) but it is not installable
                   Recommends: libgstreamer0.10-0:armhf (>= 0.10.15) but it is not installable
                   Recommends: libspeex1:armhf but it is not installable
                   Recommends: libvorbis0a:armhf but it is not installable
                   Recommends: libvorbisenc2:armhf but it is not installable
                   Recommends: gstreamer1.0-libav:armhf (>= 1.2.0) but it is not installable
                   Recommends: gstreamer1.0-plugins-bad:armhf (>= 1.2.0) but it is not installable
                   Recommends: libwebkit2gtk-4.0-37:armhf but it is not installable
E: Unable to correct problems, you have held broken packages.

=====

So I would like to think that I have done one of a few things incorrectly:

1) Attempted to install an app either meant for a different distro. (AKA = You Shall Not Pass)

2) I am running the incorrect distro.  (Possibly changing distros might solve this issue.)

 

Any Assistance, would be greatly appreciated!

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...