Jump to content
Welcome to our new Citrix community!
  • 0

AgentLocalMappedAccountHelper instance not initialized.


Ronnie Pedersen

Question

I've recently updated WEM from 2012 to 2112. After updating the agent on my VDA, I get the following error in Event Viewer every 30 seconds 

 

Event 0, WEM Agent Service: 

 

Value cannot be null.
Parameter name: AgentLocalMappedAccountHelper instance not initialized.

 

I can't find anything anywhere about it... But Id like it to go byebye. 

 

As far as functions go, I haven't notived any issues and the agent is communicating fine with the server. Have yet to promote to production though :).

 

 

Link to comment

15 answers to this question

Recommended Posts

  • 0
On 1/27/2022 at 9:51 AM, edgillilandgreatdane.com said:

Having same issue with 2112, and VDAs/infra with Jan 2022 updates installed. Opened a ticket with no progress yet. 

 

It does seem to be related to certain type of mappings as the errors don't show on a fresh start.

 

Has anyone had any luck with this? I'm not getting anywhere really with support. I get more like 3-6 logs per second on affected VDAs.

 

For me, I see it on some VDAs and not on others. I can't trace it to a particular user/group assignment. No actions seem to be failing that I can tell. This is something that would need to be rolled back to 2109 or possibly wait until 2203

Link to comment
  • 0
On 2/18/2022 at 4:25 AM, Daniel Richert1709163213 said:

Hello,

I also created a ticket, unfortunately no meaningful progress either. Has something happened with you, is there more info?

Nope, no luck. They asked for debug logs which I gave, but it's hard since it can't be traced to a single user. I don't think it's a big deal overall since I haven't noticed anything stopped working, but it is adding overhead to the service and clogs up the logs.

Link to comment
  • 0
23 hours ago, Chris Rowland1709155631 said:

I had this exact issue a month or so ago across two different farms and spent some time with Citrix support on it.  Eventually we found that stopping the WEM Agent service, deleting the local agent cache and database, and then restarting the service resolved the issue.

Thank you! This does appear to work. On my VDAs where it was occurring, this is what my cache directory looked like. Those SDF files aren't normal..

 

 image.png.e83911e23751faca60c16bbea078d595.png

Link to comment
  • 0

Hello,

 

In our environment we have all Log Windows Event and FSLogix as well as WEM Agent local database on a persistent disk E:\ (vDiskCache) moved via GPO. although both files WEM Agent local database will be overwritten at each reboot worker, but the date created remains with files. I therefore recommend deleting both files completely with every reboot

 

every Woker  (It is important not only to make maintenance mode machine. but with one computer GPO than for all workers)

 

  • Stop wem agent service on wem agents Go to this folder on the wem agents->C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\Local Databases.                       (If you have via GPO Move to other Disk , WCDisk (Exampl E:\WEMCache), then you find both Files)
  • Delete both files under the local database folder.   (If you have via GPO Move to other Disk , WCDisk (Exampl E:\WEMCache), then delete both Files)
  • Start wem service and netlogon service on the wem agents And then run this below command in command prompt to manually refresh cache on wem agents- 
  • C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\AgentCacheUtility.exe -refreshcache (after you run this command check on wem agent if the deleted files are getting recreated or not)
  • Test with this machine if the issue still
  • You can create bat files and run via GPO (Computer GPO)
  • Exempel:

wem.bat

 

net stop "Citrix WEM Agent Host Service" /y

del /f E:\WEMCache\LocalAgentCache.db

del /f E:\WEMCache\LocalAgentDatabase.db

net start "Citrix WEM Agent Host Service"

net start "Netlogon"

"c:\Program Files (x86)\Citrix\Workspace Environment Management Agent\AgentCacheUtility.exe" -refreshcache -brokername:BrockerServer

 

 

Edited by Kaveh Shafaati
Link to comment
  • 0

Hello, I have the same issue on an WEM upgrade from 2103 to 2203 but only on WemAgent on PVS Target Devices VDA. Not on normal VDA. When users are logging, the WemAgentHost Service crashed... 
I tried your solution but it's not working. 

I tried to uninstall and reinstall WEM Agent in 2203 directly on my PVS Master image : I have no errors but when I published the new version on target devices, problem appears. 

 

Any idea ?

 

Thanks in advance

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...