Jump to content
Welcome to our new Citrix community!
  • 0

MACOS Monterey and latest Citrix Issues


John Thomson

Question

Hi All,

 

What is happening with the plethora of issues we are having with Monterey and Citrix...? Is Citrix looking at it?

 

My setup - MACBOOK Pro 14 with 2 x Dell 27 ext monitors.

I have found the latest version of Citrix Workspace is the best for my mac but still has many issues. I have tried a couple of other version but they were worse.

 

Sometimes: missing cursor

                        All screens flash black and white (blank) for 10-20 seconds.

Always: Citrix bar at top will not let me go full screen on one of the external screens

                when I swipe right or left to get away from the Citrix session and click on my personal emails... it goes straight back to Citrix again.

 

Willing to help!

jsgthomson

Link to comment

3 answers to this question

Recommended Posts

  • 0

As of 2022-01-20, I'm on latest Citrix receiver & latest macOS Monterey 12.1 and I also have issues which were not there until recent updates. 

On launch, my remote desktop is maximised only on the laptop screen.  Like this, the mouse doesn't seem to work on remote desktop.
I can fix the mouse & get it to span screens by hovering over the top left corner, clicking on the green un-maximise button, then clicking on it again.

I think the lost pointer may happen when I move close to the bottom of the laptop screen & the macOS dock pops-up. 
I seem to be able to get the pointer back in the remote desktop if I swipe to a macOS desktop, click on anything, then click on the Citrix icon in the dock.

 

On one occasion, I could see a few tiny colour speckles (against a large white window) on the external screen, much like you get with failing video ram. 
Was not there on the laptop screen, or on either screen when swiped to a macOS desktop.  I've not seen this since though.

Link to comment
  • 0

Yup doc here that accesses hospital desktop and imaging offsite. Citrix workspace won’t start up - none of my remote access apps start in Monterey (12.2 and tried 12.2.1). Didn’t notice Citrix was only supported to 12.1 until I had this problem and checked. Tried reinstalling Citrix workspace but that didn’t work. Didn’t want to try to downgrade to 12.1, so bought an new ipad so I can access hospitals imaging off site…

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...