Jump to content
Welcome to our new Citrix community!
  • 0

Lost disk when move action throw an error


Josip Scaronantalab

Question

Hi,

 

a few weeks ago we tried to move few disks from one NAS to another. In this process, we get an error message (I don't know what was the error) for the first and second disk, but all the rest was moved without any issues. After we moved all the disks we needed, we found out that we're missing those 2 disks that throw an error.

 

After few weeks of investigation, we didn't get any closer, so this is our last chance in order to save data from those 2 disks. I think the problem is similar to this one XenServer Lost Virtual Disk or this one Xenserver 7, VDI copy action failed, VDI's now missing

 

First disk was "SQL 2015 - 400" and was 400GB, and second one was "SQL 2015 - 100" with 100GB.

 

The problem is that when we open OVH  control panel we can see that our partition has a size of 1500 GB and 1008 GB is used.

image.thumb.png.42629fda5c413e229bbf7e43034fde07.png

 

When we login to XenCenter we see different numbers. Disk size is 1500 GB but used is 552 GB

image.thumb.png.20e52442b9936ca80a2685b0ca9e832a.png

 

There is a difference of almost 500 GB which is a similar size as those 2 disks together (400 GB & 100 GB). We tried to contact OVH support many times, but their response is that's not their business and they can't help us. 

We think that those 2 disks still exist somewhere, but are somehow detached from the pool (we even have ID of the missing disks from the log file we've found). Question is do you guys have any suggestions on what to try next? Are there any console actions we can try?

 

 

Dedicated server (OVH):

  • System (OS): xenserver6_64
  • Boot: hd (Boot from hard drive (no netboot))
  • Datacenter: Gravelines (GRA1) - France
  • Rack: G114A25

 

XenServer:

  • XenServer build date: 2014-09-26
  • XenServer buid number: 70446c
  • XenServer version: 6.2

 

 

Also,

  • There is no backup
  • We can't see vhd in /var/run/sr-mount/
  • We have a snapshot (yellow line in the first picture with the size of 456 GB (and that's exactly the difference between used storage on OVH control panel and XenCenter), but we don't know how to use it

 

Thanks in advance,

J

Link to comment

7 answers to this question

Recommended Posts

  • 0

Hi Josip,

 

Few tips:

1. Upgrading to a not EOL and not even security supported anymore version of XenServer. 6.2 is VERY old and a LOT happened in terms of updates/security and even stability since. I know you are not in a good place now, because upgrading 6.2 will be a serious operation requiring assistance.

2. In general, I would say it's complicated to track down exactly what happened, this will probably require some deep investigation on your machines. However, to do that, you need support. But I suppose nobody will give you support on a version that's 8 years old without any updates since a similar period of time. That's why it's critical to get professional support on such an important piece of infrastructure (virtualization platform).

3. If you have backups (and I hope you have), you might take your loss and restore the backup, frankly that's the fastest option if you don't know how to investigate further on your existing issue.

4. As we are based in France, we know OVH pretty well, and we have customers in their datacenter. However, we operate on the hypervisor support, while OVH is only responsible for hardware support. So their answer sadly make sense in your situation.

 

Frankly, I would go for an analysis of your current infrastructure to get a fresh one, while working with a skillful company that can help you on that. Having 6.2 in production is sounds at least VERY risky to me nowadays.

Link to comment
  • 0

Thank you for a quick response. 

 

We're in the middle of a "migration" to a new system so hopefully a few months from now we won't have this kind of problems anymore. Until then everything should run on the current configuration as is now. Unfortunately, we don't have any backups for this 2 disks and that's the biggest problem. The whole configuration is inherited from another company so we don't know what were they doing in the past.

 

I think the last thing we can do is somehow use that partition snapshot of 456 GB that we can see but we can't find any instructions. OVH told us they don't have any instructions for Citrix so we're again on our own. If anyone has any suggestion on how to use the snapshot we'll be very thankful.

image.png.7d36394bebb2e8ee01312bf77a56552b.pngimage.png.4fe12e0660f6d67a65266ff6077d84d8.png

 

Also, we'll open a support ticket to the OVH again and ask them why is there 1008 GB of used data if we can only see 552 GB used. Maybe they are responsible for this issue, so they take a closer look and find something that can help us.

 

Josip

Link to comment
  • 0

If this is an LVM disk, you could try to recover it with various commands to wake it up (e.g., "vgchange -ay") or if the disk LVM DB is corrupt, you could try to do a recovery of you have a backup or archive save of the DB. Not for the faint-of-heart, any of this, alas, and no guarantees.  If not an LVM volume, hard to say what options might exist. If a Linux disk you could always try to boot XS in single user mode and try running fsck on that disk.

 

-=Tobias

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...