Jump to content
Welcome to our new Citrix community!
  • 3

Ghost sessions after upgrade to 1912 LTSR CU4


Jozef Jonas1709152693

Question

Hi,

 

after upgrade from 1912 LTSR CU3 to CU4, we noticed that few users don't have their user name in Citrix Studio. So I checked the user directly on the VM and found out that the user seems to be OK, but when I tried to logoff that user, I was not able to do so. Simply using Task Manager or logoff command doesn't work, nothing happens, even no attempt for logoff in Citrix Profile Management log. Only killing LogonUi.exe process helps to logoff the user.

This issue seriously affecting also regular reboot of the VMs as they time out during reboot process as the reboot takes very long time due to this logoff issue and then they keep turned off.

 

Noticed also, that the user "ghost session" is taken as UnstrustedUserName when list the user via Get-BrokerSession and ConnectionMode is Unbrokered. Weird...

 

Environment:

Everything (Lic. server, SF, DC, VDA) successfully upgraded from 1912 LTSR CU3 to CU4.

Windows Server 2019 with latest patches from December.

Citrix Profile Management used for roaming profiles.

 

Thanks for help.

Joe

 

1_studio.jpg

2_brokersession1.jpg

3_brokersession2.jpg

Link to comment

18 answers to this question

Recommended Posts

  • 0

Same problem here.

Also running Windows Server 2019 with latest Win-Updates.

Problem appeared immediately after updating VDAs from CU3 to CU4.

Happens with approx. 1% of daily user logons.

We have Citrix Profile Management for roaming profiles and FSLogix for Office 365 (Outlook- and Onenote-Cache).

We do not use AppSense and/or WEM.

Malware protection used is Kaspersky.

 

Link to comment
  • 0

Hi,

 

no, nothing new. Citrix requested us to send them full memory dump of affected VM but we already downgraded to CU3 so everything is working fine now and I have no plan to update production environment back to CU4 just to get the dumps. Have seen this issue also on our Test server so waiting until it reveals and then will get it for them. 

 

Weird thing is, that in US region we don't have this issue and we didn't have to roll-back, only in EMEA. The same domain, the same OS and configuration except some different apps on top of it, but that's it.

 

Joe

Link to comment
  • 0

We experienced this same issue. It happened abruptly which was strange, we had been on VDA 2006 for ~8 months or so before it started occurring. Prevailing thought was that it was Microsoft CU related but we never removed to test.

 

CVAD

Server 2019 with latest patches (December and everything previously)

Tried VDA versions 2006 - 2112. All had the same issue with ghost sessions. 

Was a combination of FSLogix + UPM. Removed UPM as part of troubleshooting but still occurred. Container would mount successfully and then terminate at '===== Begin Session: StartShell'.

 

Ending the 'winlogon.exe' process for the session would clear it out. Analyzing the wait chain on that process showed it stalling on 'LogonUI.exe'. Ending that process would let winlogon.exe exit as well, so either one works for clearing them.

 

We reverted to 1912 LTSR CU3 which resolved it.

Link to comment
  • 0
2 minutes ago, Gerald Piskernig said:

We have the same problem, opened a support case, but no answer yet. Have you been able to test it yet?

Thank you!

 

We´ve got the same issue on 2112 an got the DLL to replace . We´ve tested the "fix" and its working. No Ghost sessions the whole day.

 

you can read this topic, I think its the same issue. One User provided a workaround 

https://discussions.citrix.com/topic/393608-logonuiexe-sessions-disconnected/page/8/

 

cheers

Link to comment
  • 0
On 2/2/2022 at 1:19 PM, Gerald Piskernig said:

We have the same problem, opened a support case, but no answer yet. Have you been able to test it yet?

Thank you!

 

Hi, still testing. Ghost sessions look fine, they seem to be gone now, but the whole issue doesn't look to be solve completely. I found three servers down after reboot, which is probably still the consequence of not being able to logoff some stuck users(despite there is no ghost session in Studio) and the whole reboot process timed out. Still investigating. Will keep you updated.

Link to comment
  • 0

I have the problem with the CU4 and the fix posted here did not help unfortunately.
After that I just installed CU3 & here the problem reappears.
Next approach would now be reinstalling the director?
Or does anyone have another idea?

EDIT:
CU5 same Problem.

Edited by Carsten Siemer
new info
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...