Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Studio Device Collection no add Maschine


Marc-Alexander Graumlber

Question

HI,

 

after Upgrade XenDesktop and PVS to 2112. I cloud no add Maschine to a Maschine Catalog anymore. When i try to add maschines with the Wizard in Studio I get an error Message.

Here are the Error Message: Cloud not load file or assembly'PvsUtlity', Version=1.0.0.0,Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

 

Maybe someone can help me?

 

Thx a lot.

Link to comment

9 answers to this question

Recommended Posts

  • 1

Just to let you everyone know: I successfully used this fix today as suggested by OP but it only worked when I followed all 3 following steps:

 

1. Quickly (temporary) install the 2112 version of PVS server components (= only the basic next-next installer without any config) on some temporary server.

2. Copy PvsUtility.dll and CDFNet.dll from this temporary 2112 PVS Server to the Server running Citrix Studio into the following folder: "C:\Program Files\Citrix\Desktop Studio" (I tried copying them from an older existing PVS server => it does NOT work !)

3. REBOOT the server running Studio that you just copied the 2 files to. (I tried without the reboot => it does NOT work !) 

 

Thx to OP for sharing the fix

  • Like 1
Link to comment
  • 0
On 12/21/2021 at 11:55 AM, Marc-Alexander Graumlber said:

I found a solution copy PvsUtility.dll and CDFNet.dll from PVS Server on the Studio Server C:\Program Files\Citrix\Desktop Studio.

What version was your PVS server? I tried your solution (these files did not exist no the studio server) but the I get another error message...

 

Link to comment
  • 0
On 2/28/2022 at 6:17 PM, Andy Vanderbeken said:

Just to let you everyone know: I successfully used this fix today as suggested by OP but it only worked when I followed all 3 following steps:

 

1. Quickly (temporary) install the 2112 version of PVS server components (= only the basic next-next installer without any config) on some temporary server.

2. Copy PvsUtility.dll and CDFNet.dll from this temporary 2112 PVS Server to the Server running Citrix Studio into the following folder: "C:\Program Files\Citrix\Desktop Studio" (I tried copying them from an older existing PVS server => it does NOT work !)

3. REBOOT the server running Studio that you just copied the 2 files to. (I tried without the reboot => it does NOT work !) 

 

Thx to OP for sharing the fix

This solution solved the problem for me

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...