Jump to content
Welcome to our new Citrix community!
  • 0

.NET Framework 4.7.2


Richard Olah1709161669

Question

I need to create a new application and one of the prerequisites is that it needs .NET Framework 4.7.2. There is also a need to upgrade the platform layer with 1912 CU4. I have performed the following steps.

 

1) Created new platform layer to ascertain what prerequisites are need for the VDA installation and cancel the layer.

2) Created new OS version and installed the prerequisites (Visual C++ 2017) plus .NET Framework 4.7.2

3) Checked the registry to ensure the correct version of .NET Framework is showing

4) Created new app layer for application and linked to the above OS version

5) Tested that the application works before sealing the layer

6) Create new platform layer, join domain  install 1912 CU4 VDA and PVS Target device agent and run PVS target optimiser before sealing layer

7) Created image template with just the application, OS and platform layers and publish to PVS

 

The application no longer works, doesn't launch, event viewer reveals generic .NET framework error. 

 

Anyone have any ideas on this?

 

Link to comment

5 answers to this question

Recommended Posts

  • 0

No there are no other apps in the image, i stripped all apps from the image template with the exception of the new app which works in the application layer

 

The image contains only the below;

OS layer - 1912 CU4 VDA prerequisites and .NET Framework 4.7.2

Platform layer - 1912 CU4 VDA and PVS Target device

Application layer - single application - which opens in the layer before sealing

 

How do i publish a test image with just platform layer and application layer. In  ELM you have to choose OS layer?

 

Link to comment
  • 0

This is the second time i have tried , it doesn't work. I wondering if there is a conflict with the VDA in the platform layer, it works on a standard 2016 server with.NET Framework 4.7.2 and no Citrix components installed. I may have to try with .NET 4.7.2 in the application layer, i know this is not recommended, what are the downsides to this other than having to update it in the application layer?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...