Jump to content
Welcome to our new Citrix community!

When connecting through Netscaler Gateway getting authentication prompt twice with Citrix Workspace


Nassif Khoury

Recommended Posts

When connecting through Netscaler Gateway  we are getting authentication prompt twice with Citrix Workspace noting that we have checked the box on the storefront related to Pass through citrix gateway,we have 1 vpx server with one citrix gateway that point to our strorefront server (worth mention here that we have only one store deployed)so through web browsers the users are authenticated one time when they only reach  the gateway but when we use citrix workspace and put the citrix gateway link inside it we are prompte for a user name and password two times the first time for the gateway and the second time when it reaches the store front server 

Appreciate if any one can help with this.

Link to comment
Share on other sites

Which version of netscaler are you running and are you using classic or advanced authentication policies?
Are users connecting via browser or workspace app (receiver)? (I think you confirmed both above, but wanted to make sure.) Different issues can impact the web client vs. workspace app differently.  (I just want to confirm.)

What authentication are you using, anything more complex than ldap that might involve otp or other nfactor considerations?  There might be other considerations affecting workspace app only?

 

Gateway may require a traffic policy for web SSON for the advanced engine instead of just the session policy setting for "passthrough to web" (on the client experience tab; not just the ica/published apps tab).  See:  https://www.carlstalhood.com/category/netscaler/netscaler-12/netscaler-gateway-12/#trafficpolicy

 

You might also have an issue on the storefront side for accepting credentials from gateway, but I would start with this. If web is working but clients are, it might be something else.  

On StoreFront, be sure both the Store and the Receiver for web have authentication from gateway enabled.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...