Jump to content
Welcome to our new Citrix community!

Gateway yielding 403 forbidden (files missing in /netscaler/) with 13.1: Build 9.60.nc


Recommended Posts

Fresh Xen VPX. Any gateway vserver config, any portal theme, yields 403 errors. Upon inspection, looks like /logon/ files are missing

 

ns01 Primary> show ns version
        NetScaler NS13.1: Build 9.60.nc, Date: Nov 17 2021, 08:15:12   (64-bit)
 Done
ns01 Primary> shell
root@ns01# find / | grep -i logon
/netscaler/ns_gui/vpn/media/Button_LogOn_disabled.png
/netscaler/ns_gui/vpn/media/Button_LogOn_disabled_long.png
/netscaler/ns_gui/vpn/media/Button_LogOn_hover.png
/netscaler/ns_gui/vpn/media/Button_LogOn_hover_long.png
/netscaler/ns_gui/vpn/media/Button_LogOn_idle.png
/netscaler/ns_gui/vpn/media/Button_LogOn_idle_long.png
/netscaler/ns_gui/vpn/media/Button_LogOn_pressed.png
/netscaler/ns_gui/vpn/media/Button_LogOn_pressed_long.png
/netscaler/ns_gui/vpn/media/logonbox.png
/var/netscaler/help/help/im/logon_105.png
/var/netscaler/gui/vpn/media/Button_LogOn_disabled.png
/var/netscaler/gui/vpn/media/Button_LogOn_disabled_long.png
/var/netscaler/gui/vpn/media/Button_LogOn_hover.png
/var/netscaler/gui/vpn/media/Button_LogOn_hover_long.png
/var/netscaler/gui/vpn/media/Button_LogOn_idle.png
/var/netscaler/gui/vpn/media/Button_LogOn_idle_long.png
/var/netscaler/gui/vpn/media/Button_LogOn_pressed.png
/var/netscaler/gui/vpn/media/Button_LogOn_pressed_long.png
/var/netscaler/gui/vpn/media/logonbox.png
 

Tried reapplying firmware to VPX from build-13.1-9.60_nc_64.tgz. No change.

Link to comment
Share on other sites

Same here with the ESXi VPX.

 

I have just deployed two new VPX instances. Something is wrong with the build 9.60.nc:

 

NetScaler NS13.1: Build 4.44.nc

root@ns# find / | wc -l
   50536


NetScaler NS13.1: Build 9.60.nc

root@ns# find / | wc -l
   49880


I will probably go back to version 4.44.

  • Like 1
Link to comment
Share on other sites

On 11/25/2021 at 5:20 AM, Joumlrn Rusch said:

Same here with the ESXi VPX.

 

I have just deployed two new VPX instances. Something is wrong with the build 9.60.nc:

 

NetScaler NS13.1: Build 4.44.nc

root@ns# find / | wc -l
   50536


NetScaler NS13.1: Build 9.60.nc

root@ns# find / | wc -l
   49880


I will probably go back to version 4.44.

Thanks for confirming. I will probably do the same. Looking for Citrix to acknowledge this as a regression in 9.60.

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...
  • 2 months later...
On 1/4/2022 at 9:42 AM, Mohammad Ahmad1709153862 said:

ADC 13.1 have missing folder of citrix getaway  , you need to download below file and use winscp to add the folder in that path /var/netscaler

https://citrix.sharefile.com/share/view/s8637abcf497a4a89bfef58a7926c6f87

 

Thanks this was the real issue, it fixed the problem on  NetScaler NS13.0: Build 85.15.nc

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...