Jump to content
Welcome to our new Citrix community!
  • 0

Workplace apps are no longer launching.

Brian Gackenbach


Got a new PC, and I use it to log into Cerner (Medical records EMR system) from my home.  I installed the workspace app and it worked fine immediately after install.  Now, a week later, I need to work from home on some patient records, and when I click the link that normally launches Cerner, I just get the hour glass for a few seconds, then nothing happens.  I've rebooted several times but nothing changes.

Next, I tried to uninstall, and it just hangs on the "Initializing..." screen and never uninstalls.   Was going to try a fresh install, but I can't even uninstall it!  Won't allow me to install over it, as I get a message that says I already have the latest version installed!


I'm at roadblock here guys.  I saw a post about a Clean-Up utility for Citrix receiver, but the download button is greyed out for me, I can't download it.


Any help would be appreciated.  Thanks!


Link to comment

10 answers to this question

Recommended Posts

  • 1

Hey Brian,


I fixed the issue after tinkering around.


Step 1)  Follow this guide https://support.citrix.com/article/CTX137494 and force the uninstall,  then cleanup ALL the registry files.

Step 2) Download and install N-1 version of Workspace (2108,   NOT 2109 the latest buggy one).


Works for me now.


Important note for step 1...  make sure after you run the cleanup utility,  you restart ur PC,  then do the registry cleanup,  then install 2108.





PS: let me know if it worked for you too.


  • Like 2
Link to comment
  • 0



I am getting the EXACT SAME issue after updating to the new Citrix Workspace version 'Workspace app 2109.1'.


This is so frustrating,  as I am in the same boat as you...   Cant uninstall the current version (to try a re-install) - the uninstall program just sits on "Initializing",  and Can't pipe any ica files into the Citrix Workspace (to open the VDI Connection).


Citrix !   Please look into this issue,  it seems like it is occurring for multiple people.






Link to comment
  • 0

Isn't there anyone that knows how to fix this?  I mean...this seems like a SERIOUS issue if your users can NOT even uninstall your software.  Since my original post....I've installed a system repair tool called Restoro and had it analyze my system.  I've been also getting some BSOD and it is indicating that they are being caused by a Workspace App file.  I'm away from home at this moment and not at the desktop PC so can not provide the file name.  But perhaps one of these BSOD's that I experienced early on now has Workspace borked and inoperable.  Regardless, there MUST be a cleanup utility or some way to uninstall, so I can reinstall.


I'm tempted to take a chance and just purchase this Restoro application and see if it will fix the issue...but really disappointed that I'd have to purchase a 3rd party application to simply be able to uninstall or fix this.

Link to comment
  • 0

The only way I could fix this was to use a completely different PC/Laptop (had to rebuild an old 8 year laptop), with an older version of Citrix Receiver Installed.    


The Issues with Workspace app 2109.1' mean my most recent computer (i.e. new Laptop) can no longer Open Remote Virtual Desktop Images  (when it had previously been able to do so for the past 2 years.


It's not good how we can't even uninstall the current version of Workspace to then go back to x version to get things working again.



You should consider releasing a new version of the Workspace application,  just so the uninstaller is fixed.


Link to comment
  • 0

That's great Jeff!  Thanks for sharing the link.  I just bookmarked it, and will try it this evening when I get home from work.  One question though on Step 1).  After I run the Cleanup Utility, do I need to cleanup the registry files, or does the utility do that?  Hoping the utility, as I'm a n00b when it comes to messing around in the registry.


Lastly, having some trouble finding the previous version 2108, if you have that link handy too, that would be handy, or I'll keep digging around.


I'll update you later this evening!  Thanks again!




Think I finally found the link to 2108:   https://www.citrix.com/downloads/workspace-app/legacy-workspace-app-for-windows/workspace-app-for-windows-2108.html


Edited by Brian Gackenbach
update with link to 2108 for any others that may require it.
Link to comment
  • 0
On 10/19/2021 at 2:07 AM, Riley Harshbarger said:

Having the same issue here; however, because of the way my company is set up, can't download the Cleanup Utility Jeff mentioned. Did anyone else have success with other methods?


I was facing this issue on my PC, I have created another user account on the same machine and Citrix workspace started working with this new user account. Not sure you have luxury to do that on company pc or may be sys admins can.


I didnt try uninstalling with the new user account, I will give it a try towards end of the day.


Just tried uninstalling with the different user account and it worked. Restarted PC and installed earlier version of Citrix workspace and now I am able to access without any issues.


Hope it helps!




Edited by Hemanth Kumar
Just tried uninstalling with the different user account
Link to comment
  • 0

For whoever is still having this issue and unable to use the Cleanup Utility, this is the brute force nuke method to fully uninstall it. The pesky Citrix Workspace Updater Service is what got originally in the way.


1. Open task manager, and end any citrix tasks. While in task manager, go to the services tab and sort it by "description". Look for the one that has citrix in the description, it's an updater service. Right click it and choose "stop".

2. Go to C:\Program Files and delete the citrix folder

3. Go to C:\Program Files (x86) and delete the citrix folder in there as well

4. Empty your recycle bin to make sure those are fully deleted

5. Using a program like CCleaner, run the registry cleaner tool. There should be a bunch of registry errors that it picks up because of your deleting of these files. Clean all those registry errors.


Citrix should now be deleted/uninstalled according to windows. Restart, and you should now be able to install the older version of Citrix that doesn't have the issue mentioned.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...