Jump to content
Welcome to our new Citrix community!
  • 0

Windows 10 21H1 Update Issues


Darin McClain

Question

So, I haven't even started to address this first issue, I just worked around it for now, but I wanted to mention it because it could be related to my current issue below. The VMXNet3 drivers are bugged out after I publish a new image based off the 21H1 update. Like, driver files missing bugged out. I have to manually extract the drivers from the VMTools ISO, then from device manager, point to them to get it working again. The OS layer and Platform layer do not have the issue. 

 

My latest issue, on some (not all) of my users that got updated, they are getting prompted to re-install printer drivers that I already pre-installed on the OS layer. But, even after you hit install and all is good, once you reboot, it comes up again. This is expected due to user layer capabilities of course. So, I'm at a loss how to fix this without wiping the user layers of those effected. Preliminary guess on how many users are effected, about 20%, but still too early to tell for sure, I just really hope it doesn't get any worse; not going to update any more machines yet. :(

 

I'm hoping someone has as trick up their sleeve for me? I definitely have a love/hate relationship with App Layering! haha 

Link to comment

1 answer to this question

Recommended Posts

  • 0

Update to this issue:

 

Finally got the time to invest into this. Very long story short, my View Agent layer was breaking my templates, causing the VMXNet3 NIC drivers not to load, and I think it was affecting printer drivers as well, TBD. Once I re-did my agent layer, all was good there, until I discovered my scanner drivers were still affected. I traced that back to the platform layer. I went back to the earliest version, but it breaks the scanner drivers as well, and if I don't include the platform layer at all, the scanners work fine.

 

So looks like so far, the 21H1 update has required about 8 hours of troubleshooting to isolate the issues, and I still have yet to redo/test my platform layer that thank god I kept notes on everything I did to it the last time I had to rebuild it. This will by my 3rd rebuild of the platform layer. Not looking forward to the surprises the Windows 11 update has in store for me! ?

 

Darin

 

EDIT: Ended up having to redo my 21H1 update on my OS layer, and roll back to my oldest version of Platform layer after that to fix all my drivers. Didn't have to recreate platform layer from scratch thankfully.

 

EDIT 2: I tried adding another scanner driver, and discovered my view agent was yet again breaking that driver. So I had to redo my agent layer a 3rd time. (maybe I should not be loading scanner drivers in my OS layer though). I discovered my print drivers issues were not resolved, and ended up having to redo the platform layer from scratch after all to fix them. I load my printer drivers in my platform layer. Whatever corruption was happening, USB printers would not load drivers that were pre-loaded or from windows update.

 

Edited by Darin McClain
update
  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...