Jump to content
Welcome to our new Citrix community!
  • 1

Workspace app launcher screen won't open


Gwyn Williams1709162899

Question

Having installed Citrix Receiver/Workspace app on thousands of machines in the past (either manually or via SCCM) I've never come across this problem before...

 

When the user double-clicks (or right-click and Open) on the Citrix Workspace icon in the system tray, nothing at all happens. No error message either.

 

So I'll rewind a bit. I tried to deploy 2108 to this machine (and several other machines) using SCCM. It had succeeded on all machines apart from this one, so when I checked the machine I saw there was an old install of Citrix Receiver 4.12 on there, which had been partly removed but had parts left on there. I presumed that this was unable to be uninstalled and was therefore stopping the 2108 from installing. I tried to manually re-run the silent install command for 2108 but this time with the /forceinstall switch, which apparently meant that I would not need to run the Receiver Cleanup Utility. This switch did nothing to help, so I resorted to the Cleanup Utility. This completed the uninstall, and after a reboot, and then an install of 2108, and another reboot to get SSON working, I tested. I saw that the application launcher doesn't open, and it not opened once for me.

 

The Connection Center opens fine, but obviously there are no sessions running.

 

I then tried to uninstall Workspace app, then uninstall Edge WebView2 Runtime, then I tried 2109, but this behaves in exactly the same way.

 

The only relevant warning/error I can find in the logs is this:

 

 

Log Name:      Application
Source:        Microsoft-Windows-RestartManager
Date:          01/10/2021 11:45:52
Event ID:      10010
Task Category: None
Level:         Warning
Keywords:      
User:          ######
Computer:      ######
Description:
Application 'C:\Program Files (x86)\Citrix\Citrix WorkSpace 2108\TrolleyExpress.exe' (pid 19856) cannot be restarted - Application SID does not match Conductor SID..

 

 

Any idea what I can try next?

 

Thanks.

Link to comment

1 answer to this question

Recommended Posts

  • 0

I am hoping that someone has some information on this as well. Accidentally had 5 of my machines upgrade to 2109 and now they longer connect to xendesk. uninstalling and cleanup app did nothing. Essentially I had to reimage an entire machine to get it to work. 

 

https://discussions.citrix.com/topic/414499-workplace-apps-are-no-longer-launching/

 

where the guy said he had to rebuild his machine.

 

Also, see his thread as it may pertain to you as well.

https://discussions.citrix.com/topic/414100-citrix-launch-is-blocked/#comment-2084751

Edited by dsmith883
Adding extra information
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...