Jump to content
Welcome to our new Citrix community!
  • 0

Problem connecting to Citrix Hypervisor 8.2 after changing network configuration


Edvin Demendi-Tallo

Question

Hi,

I have a Citrix Hypervisor installed on an Asus mini PC PN50. It worked great till few days ago when I decided to change my router settings and change the default 192.168.1.1 - 255.255.255.0 to 16.1.1.1 - 255.0.0.0.

I noticed that the host machine starts up with an error:

[Failed] Failed to star Load Kernel Modules

and transitioning to the Configuration menu is slower because the system is seemingly stuck on message:

Reached target System Initialization

I also noticed that the IP reservation set up in the Configuration menu is not valid anymore so I did an Emergency Network Reset, and set the

Static IP to 16.1.1.5

Network to 255.0.0.0

Gateway 16.1.1.1

DNS 1.1.1.

 

After doing this the machine rebooted and I was able to see the connection in the router LAN devices list.  Now i tried connecting via the Citrix XenCenter console and got the following error:

Unable to connect to server '16.1.1.5'

The connection was refused

Check that Citrix Hypervisor is configured correctly on 16.1.1.5 and try again.

 

I managed to find a post for a similar issue where it was advised to check the service xapi status

I logged in over ssh to my host and ran the command and I got the following:

Redirecting to /bin/systemctl status xapi.service
xapi.service - XenAPI server (XAPI)
   Loaded: loaded (/usr/lib/systemd/system/xapi.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/xapi.service.d
           └─local.conf, slice.conf
   Active: failed (Result: start-limit) since Sun 2021-10-03 12:03:51 CEST; 4min 19s ago
  Process: 6131 ExecStopPost=/usr/bin/rm -f /var/lock/subsys/xapi /var/run/xapi.pid /var/run/xapi_startup.cookie /var/run/xapi_init_complete.cookie (code=exited, status=0/SUCCESS)
  Process: 6121 ExecStop=/opt/xensource/libexec/xapi-init stop (code=exited, status=0/SUCCESS)
  Process: 5973 ExecStartPost=/usr/bin/touch /var/lock/subsys/xapi (code=exited, status=0/SUCCESS)
  Process: 5972 ExecStart=/opt/xensource/libexec/xapi-init start (code=exited, status=2)
 Main PID: 5972 (code=exited, status=2)

 

xapi-nbd[5297]: main: Failed to log in via xapi's Unix domain socket in 300.000000 seconds
Broadcast message from systemd-journald@vm-host (Sun 2021-10-03 12:08:41 CEST):

xapi-nbd[5297]: main: Caught unexpected exception: (Failure
Broadcast message from systemd-journald@vm-host (Sun 2021-10-03 12:08:41 CEST):

xapi-nbd[5297]: main:   "Failed to log in via xapi's Unix domain socket in 300.000000 seconds")

 

I tied the following resolution methods:

1. Reseted my router based on the old backup file so i got back to the old 192.168.1.1 and 255.255.255.0  - had the same issue

2. Reinstalled the Citrix Hypervisor but preserved the previous installation trying to prevent deletion of my VMs - didn't help

3. Tried reverting to the previous backup file withing the installation menu - same issue

 

I am pretty much new to Citrix Hypervisor so sorry if I don't understand some concepts and if I am missing something obvious. If you have any tips I would kindly ask you to explain them in a bit more detail using simple terms ?

 

Any help is highly appreciated!

Link to comment

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...