Jump to content
Welcome to our new Citrix community!
  • 1

MacOS Big Sur 11.6 and Citrix Workspace 2109 - cannot open multiple apps


Betsy Fulcher

Question

I have been using Citrix Workspace for almost two years working from home - once the upgrade to Big Sur 11.6 occurred I could not open multiple apps within Workspace. I upgraded Workspace to 2109 yesterday which supposedly had a fix to this known issue and still am unable to open multiple apps. The IT department at my workplace cannot help because this is my personal computer. 

Link to comment

7 answers to this question

Recommended Posts

  • 0
On 9/30/2021 at 11:04 PM, Betsy Fulcher said:

I tried to do that and it would not let me go backwards .There is probably a way to do it I could not figure it out. 

Hi Betsy,

 

You can try with latest Citrix Workspace for Mac 21.09.1 Build and this issue should be resolved. You can download build from: https://www.citrix.com/en-in/downloads/workspace-app/mac/workspace-app-for-mac-latest.html or use Check for Update option to get the latest version.

 

Thanks,

Arpit

Link to comment
  • 0
1 hour ago, Andreas Lamecker said:

Exactly the same problem here... even after upgrading to 21.09.1. I´m running on MacOS 11.6, different browser. Even re-installing, nothing helps so far. I´m only able to open one single app.

Hi Andreas,

 

Can you try following steps:

1. Download CWA Mac latest build from: https://www.citrix.com/en-in/downloads/workspace-app/mac/workspace-app-for-mac-latest.html

2. Double click on the .dmg file. Use Uninstaller to uninstall any existing version of CWA Mac app.

3. Now using Install Citrix Workspace, install the latest version of CWA Mac app.

 

Now try launching the session. Your problem should be solved.

 

Even if this doesn't solve the problem, can you please collect the logs using article: https://support.citrix.com/article/CTX229846. Please share these logs with us and we shall be able to help out.

 

Thanks,

Arpit

Link to comment
  • 0

Has anyone received any resolution on this issue? I'm using Big Sur 11.6 and downloaded the above Citrix app from Arpit's post and still can't open 2 apps in the Citrix workspace simultaneously. My workplace hasn't been able to help me with this issue so I'm reaching out to Citrix because I hope to continue working from home. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...