Jump to content
Welcome to our new Citrix community!
  • 0

Unable to launch workspace from company website on Mac


Remco Demoet

Question

My company uses Citrix Workspace to work from home in a desktop environment. I have login details and some verification tool to sign into my account on their website and then I'm supposed to click on a link that should launch the workspace app and get me into the client. Login in works just fine but the Citrix client does not launch. I have it installed and even when I have manually opened the application it does not seem to do anything. IT says they're unable to offer support since it's external software. I have tried the same process for different apps (clicking a hyperlink to open an application on my computer) which works fine. 

 

I'm using a 2020 MacBook Pro on the latest update (11.6). I tried Safari, Chrome and Firefox. I didn't change any settings nor do I have a link or e-mailadres to setup the account within the cliënt. All I've done is install the software and attempted to launch from my company website. 

 

Thanks for reading and offering any help.

 

Remco

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...