Jump to content
Welcome to our new Citrix community!
  • 0

CVAD 1912 LTSR CU3 - In Azure - VDA show unregistered state


Lars Roar Iversen

Question

Hi.
Need help for this problem

Just installed CVAD 1912 LTSR CU3 solution in Azure with win 2019 servers. Everything works, but VDA shows in unregistered state.

 

Citrix Scout from DDC show all good.


I have run Citrix health Assistent from VDA. This show two error (and to warnings): 
    1. Registration: We are not able to diagnose the issue at this time. See CTX136668 
    2. Session Launch: VDA Appliation Launch Path: Exception happend when checking application launch path. DDC was not found

 

Timesync, ListOfddc, communication between DDC and VDA seems fine.

Tried to reinstall VDA agent  -  does not help

 

Also there is a Azure Firewall between VDA and DDC and Active Directory Controllers that can be the problem.

 

From the XDPing report it looks like it is not trying to connect to DDC on port 80, but port 0. Can it be some other program that uses port 80?

 

-------------------------------------------
From Citrix Health Analyzer report:

  • VDA software installation verified.
  • Machine domain xxxxx membership and DNS resolution verified
  • Required port: 80 access verified.
  • VDA and Controller communication verified. Step 6: Communication with Controller End. Test Success
  • Time Sync with Controller End. Test Success.
  • We are not able to diagnose the issue at this time; to further troubleshoot this issue, perform the tasks described in the following Citrix article: CTX136668.
  • Session Launch Communication Port Availability End. Test Success.
  • The Windows Firewall Service allows communication between the VDA and the Controller.
  • The "Allow time zone redirection" policy is not set. Go to the Desktop Delivery Controllers and set the policy. For more information, see CTX126099.
  • VDA Application Launch Path)  Begin. <<<< [UI Message] Exception happened when checking application launch path: DDC was not found  – <<<< Step 13: VDA Application Launch Path End. Test Error.
  • Microsoft Terminal Service License is valid
  • The Citrix HDX MediaStream for Flash Service (CtxSvcHost.exe) is not found.  [UI Message] Waring: Some services are not working (but session launch might still succeed). Check log for details

----------------------------------------------

 

XdPing report (removed the DDC servername and ip)

Controller: xxxxxxxxxx.no:0
    DNS Lookup(xxxxxxxxxx.no):
      Host Name  = xxxxxxxxxxxx.no
      Address #0 = 10.x.x.x (rDNS: xxxxxxxxxx.no) [OK]
    Ping Service: /Citrix/CdsController/IRegistrar
      Connect = Unable to open connection to xxxxxxxx.no:0
 [ERROR]

 

 

-----------------------------------
VDA event 1023: 
The Citrix Desktop Service was refused a connection to the delivery controller 'xxx' (IP Address '10.x.x.x'). 
 The registration was refused due to 'AgentNotContactable'.

VDA event 1017:
The Citrix Desktop Service failed to register with any delivery controller. 
 The service will retry registering with controllers in approximately 14 seconds. 
 Please ensure that at least one delivery controller is available for Virtual Desktop Agents to register with. Refer to Citrix Knowledge Base article CTX117248 for further information.
--------------------------------------------------
 

DDC event 1194
Registration request for worker S-1-5-xxxxxxx (xxxxxxxx) was rejected because the Broker service was unable to contact the worker during the registration process.

DDC event 1039
The Citrix Broker Service failed to contact virtual machine 'xxxxx' (IP address ). 
Check that the virtual machine can be contacted from the controller and that any firewall on the virtual machine allows connections from the controller. See Citrix Knowledge Base article CTX126992. 
Error details: 
Exception 'The remote server returned an unexpected response: (463) status code 463.' of type 'System.ServiceModel.ProtocolException'.

----------------------------------------------------

 

errorCitrix.PNG

errorCitrix2.PNG

Link to comment

1 answer to this question

Recommended Posts

  • 0

Find the solution (there was two)

Solution 1 - Azure Firewall opening
Open for ICMP both way (VDA <-->DDC)

First test is ping VDA and DDC: https://subscription.packtpub.com/book/virtualization_and_cloud/9781785280139/4/ch04lvl1sec50/a-basic-troubleshooting-flowchart

 

Solution 2 - VDA shows wrong ip i WCF/SPN - Fail worker callback using SPN HOST/VDA
We run CDFControll on DDC and active Real-time log and look for Class = AOT.  Under message field in CDFControll we see that the VDAIP was totally wrong.  (maybe firewall was closed when we installed the VDA servers/image and then ip-address get wrong. Because it was using a IP address from the Azure Firewall subnet)

On both DDC I added the registry key in the article https://support.citrix.com/article/CTX215734
(DDC will then use DNS instead og WCF): 

  • HKLM\Software\Citrix\DesktopServer\UseIPAddressFromWcf = 0       (and reboot both DDC)

So the error "AgentNotContactable" means that WCF has wrong ip on the VDA servers so that DDC can not communicate with it.

 

We first tried to delete this xml file on the VDA, but get access denied to the folder (so we go for the registry key instead). But I will believe that both solution would work.
https://support.citrix.com/article/CTX213846


Restart VDA and it shows Registered in Citrix Studio

 

 

image.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...