Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Viewer doesn't launch the virtual desktop and crashes


Philip Falk

Question

Hello,

 

When I click on the downloaded .ica file, the Citrix Viewer seems to launch (Icon in dock)  but doesn't actually open any windows. After that, the app eventually quits. I don't receive any error messages either.

I have Macbook Air 2014 and Big Sur 11.5.2.

The newest Workspace App doesn't say that it is compatible with 11.5.2, but I think that it already didn't work when I tried it once before updating to the newest OS (unfortunately I don't remember if the first time I tried was before updating or after, as I did both the same day). 

 

Are there any known fixes for this, or other people experiencing the same?

Thank you

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...