Jump to content
Welcome to our new Citrix community!
  • 0

2108 Prompting Users to Re-authenticate


Gary Chan1709160142

Question

10 answers to this question

Recommended Posts

  • 0

I have had the same problem. After updating to Big Sur 11.5.2 the Citrix workspace app (2108) keeps on prompting me to authenticate even though I am in a session and can continue to work. It is extremely annoying and the window overlaps with my other apps. If I go back to 2107, does that supports Big Sur 11.5.2?

Link to comment
  • 0

We are seeing the same problem.

 

I enabled verbose logging for Workspace App. Log shows this event every two hours when credentials are prompted.

| 08-24-2021 | 11:34:42.762 | 2875 | 259 |  DZAppChooser.m |  905 | -[DZAppChooser performReloadsTimerFired:] | LM_STORE |   LL_ALWAYS | performReloadsTimerFired called

 

It appears to be trying to refresh StoreFront for some reason, but since StoreFront session is expired it prompts for credentials. Why is 2108 trying to auto refresh in the background if I'm actively working in a Virtual Desktop and not trying to launch anything from StoreFront?

 

 

Link to comment
  • 0
On 8/18/2021 at 6:09 AM, Mallikarjun Dandoti said:

Hi Gary, what is the account(cloud or on-prem account) and scenario where users are getting re-authenticated. 

 

We are on-prem accounts,  users are getting this working from home or in the office.  Working from home they need to authenticate against our netscaler while on prem they have direct access to StoreFront.

Link to comment
  • 0

Same problems for our macOS Clients with workspace App 2108 and macOS 11.5.2 as well.  

Users connecting via Netscaler&FAS to our SF and they need to authenticate for every app they open and for every 2 hours again.  I will do some tests with 2107 today. 

 

Update: MacOS 11.5.1 and 2108 has the same behavior mentioned above. With 2107 it works as before with 11.5.1 and 11.5.2. We are considering a rollback to 2107 now. 

 

Edited by Marc Rieper
Update
Link to comment
  • 0
23 hours ago, Gary Chan1709160142 said:

 

We are on-prem accounts,  users are getting this working from home or in the office.  Working from home they need to authenticate against our netscaler while on prem they have direct access to StoreFront.

This is the same for us. We have rolled back to 2107 for now and it works normally.

 

Interestingly, we have two gateways for two different Citrix sites. The older with ADC 12.1, classic authentication, and StoreFront 7.15 does not have the prompting issue. Our newer gateway with ADC 13.0, nFactor auth, and StoreFront 1912 does have the issue. We were recently engaged with Citrix Consulting Services to build the newer gateway that has the issue. They are researching with the PM team but so far no answers.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...