Jump to content
Welcome to our new Citrix community!

Unable to import IIS certificate into Netscaler


Recommended Posts

Which firmware are you on? As it might just be a bug and it might be gui-specific.  Are you creating a certkey using the pfx or the GUI's import command (which uploads and converts)?

You can also just upload to /nsconfig/ssl directory and create certkey from .pfx without import (upload and convert).  To see if it is in fact a gui bug vs. a cert format issue.

add ssl certkey <certkeyname> -cert <file.pfx> -bundle yes -password

 

Or if the conversion works, you can use that

 

 

Link to comment
Share on other sites

  • 8 months later...
  • 9 months later...
  • 7 months later...
On 2/4/2023 at 8:38 PM, Sam Ponder said:

a workaround for me was to do the follow step in order.

  1. go to the cert to update and click update
  2. then retype the password in the password box
  3. then click  update cert and key
  4. pick your cert and click  ok

It then updates successfully.

Thanks! This worked for me. After clicking on the checkbox for "Update the certificate and key" and entering the password again. I was able to select the new SSL cert to update and didn't receive the "String length exceeds maximum [password, 31]" error anymore. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...