Jump to content
Welcome to our new Citrix community!
  • 0

OS-Layer VM hangs at boot after invoking ImportOSLayer Script


Stefan Fohringer

Question

Works like a charm with Windows 2019 server, but I cannot for the life of me get the freshly installed Windows 10 20H2 to work...

Nothing installed except machine tools.

 

Reboot after invoking ImportOSLayer hangs at the windows logo, without the any prompt. CPU usage at 100% for a 1 core.

vSphere 7.0.1, UEFI VM, happens with or without VBS enabled.

 

How would one proceed to debug this?

Do you have any tips for me?

Link to comment

10 answers to this question

Recommended Posts

  • 0

Already tried that. BIOS VM gehts imported by ELM no problem.

But adding a new version via a UEFI template also hangs at boot.

 

Either time its the compositing engine.

Which bothers me, since it works in the same environment for Windows 2019.

 

Is there any way to have the compositing engine log something?

 

Link to comment
  • 0

I found the way the compositing engine is setup up prior to booting, by looking at the dynamic powershell module loaded via ImportOSLayer.ps1

So the problem looks to be that the Windows 10 VM cannot boot the compositing engine WIM file. At least it tries to boot but hangs at the Windows logo.

 

I've tried Windows 10 2004, 20H2, and even 21H2.

With or without virtual based security. Every try a freshly installed Win10 without any 3rd party software (except vmware tools).

 

I guess I'll have to open a support case.

Link to comment
  • 0

Just reproduced this issue in a freshly installed lab environment.

 

Same versions, same issue:

vSphere 7.0u2

Windows 10 20H2 installed with March 2021 updated ISO

 

I opened a case on Friday. But this looks like a general issue to me.

Although I don't get why it should work with fully patched Win2019, but not Win10.

 

 

I'll post the result of the case here in this thread.

Link to comment
  • 0

So...
We didn't make any progress whatsoever in the support case.
I was able to reproduce the same issue in a freshly installed LAB environment.

Then, yesterday, a colleague rolled out a new host profile for the ESX hosts in the vsan cluster.

After that, I was setting up a new Win10 20H2 VM to capture some data for the case before and after machine-tools-setup.
And suddenly, everything works.
ImportOSLayer with EFI VM

I now have a working OS layer and am currently building the platform and some app layers for it.


The host profile contained 5 settings, and only one makes remotely any sense to interfere with the issue:
VMkernel.Boot.execInstalledOnly was set to true


But I still don't get...
1) whats the difference between Win10 and Win2019 regarding the WIM boot of the compositing engine?
2) how can a ESX host configuration setting interfere with the OS boot of a Win10 VM but not a Win2019 VM?


I gues I'll never know.
At least the issue still persists in my LAB environment, even with the VMkernel option set.
Maybe I'll find it in the coming weeks.

Link to comment
  • 0

I have exactly the same issue:

 

ELM 2107

vSphere 7.0u2 (vSAN, on Dell VxRail)

All layers were created from a BIOS Win10 20H02.

 

When I try to publish a MCS image (with a uEFI VMware template in the MCS connector), the WinPE can't load and start the compositing engine (stuck on the Windows logo).

When I use another MCS connector pointing to a vSphere 6.7u3 (FC SAN) with the same uEFI VMware template, it works.

When I convert the uEFI VMware template into a VM and try to boot the Windows10 20H02 ISO (on 7.0u2), it works.

 

I hope my explanations are clear.

 

Is there people having the same issues with 7.0u2 (on vSAN?)

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...