Jump to content
Welcome to our new Citrix community!
  • 0

iOS Workspace app and Azure AD auth without FAS requires re-auth at every app launch whereas desktop Workspace app does not


Brian Black

Question

I tried to summarize the problem as succinctly as I could in the title, but that was a stretch :)

 

Using Citrix Cloud services, we turned on Azure AD IDP authentication for the CVAD on-prem hosted apps site, understanding that we'd be re-prompted for authentication when launching the first app in a seamless session. This worked as expected when using desktop macOS and Windows Workspace apps--once we got through the initial double-authentication (Azure AD + on-prem AD) upon first app launch, any subsequent app launches would not re-prompt for on-prem AD authentication.

 

The iOS Workspace app appears to be a different story, though. Upon first app launch everything is the same as the desktop app, but when you hit the top pull-down menu > Home > back to Workspace app and launch another app, it's as if it pauses so long that it loses connection to the seamless session it already has, finally loads the app and presents you with the on-prem AD login again. Once past this, the app is popped into the initial seamless session, but I can't figure out why it's doing this.

 

Is this an iOS/mobile app limitation, or is there some secret app setting or Citrix policy that would make this work like the desktop CWAs?

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...