Jump to content
Welcome to our new Citrix community!
  • 0

Apps: Specific app randomly not loading, works if user launches 4-6x


Rowen Gunn

Question

Hello! I've got this horrible issue that's becoming a massive impact for our company.

 

We have an application (Great Plains) running on 2 Win 2019 servers with 2106 VDAs. When users go to launch any application (desktops are fine) from these two servers the app crashes during loading. Somewhere between 30%-90% loading the app & session will crash and the user had to launch it again, and again, and again until eventually the apps load like normal. Citrix support has not been able to determine the cause and just asks for traces and logs they don't seem to review. There's no clear event logs to explain why this is crashing, just part way during the login phase the session just self terminates with no clear reason why. Launching a desktop from these servers does works every time, it's just application launches that fail miserably. 

 

Event Logs errors:

 

The Citrix ICA Transport Driver connection from 192.168.xxx.xxx:54035 to port 2598 received an invalid packet during its SSL handshake phase.

The winlogon notification subscriber <TermSrv> failed a critical notification event.

The winlogon notification subscriber <Sens> failed a notification event.

Session 3 has been disconnected by session 3

Session 3 has been disconnected, reason code 11

 

 

--VDA version:

  • 2106 (also tried 1912.CU3)

--Number of VDAs:

  • Two

--VDA OS:

  • Windows Server 2019 Standard

--Delivery Controller Version:

  • 1912 LTSR CU3

--Number of Controllers:

  • One

--Controller OS:

  • Windows 2012

--Receiver Version:

  • Workspace 2106

--Hypervisor:

  • ESX 6.7

--StoreFront version:

  • 2106

--Number of Storefronts:

  • One

--Is NetScaler used?

  • Issue occurs with Netscaler and on Internal network

--Provisioning Method:

  • Manually deployed VMs

--The issue started on:

  • Issue existed entire time we've used these servers, does NOT occur when launching Desktop to these servers, only when launching any application hosted on the servers

--Error Message, attach screenshots if is possible:

  • No direct error messages, when the session is starting to load, somewhere between 30-70% the loading session window just closed and the entire session ends on the server.

--Troubleshooting performed:

  • Rebooted servers, upgraded VDA to 2106 from 1912 CU2, upgrade Session Recording, upgraded DC from 1912 CU2 to 1912 CU3, tried alternative login script, deleted roaming profiles for users, disabled session reliability, disabled HDX 
Link to comment

5 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...