Jump to content
Welcome to our new Citrix community!
  • 0

Cannot install Virtual Apps and Desktops 7.15 LTSR CU 7 on W2K16


Henri Louwes

Question

Has anyone encountered the issue that installation of Virtual Apps and Desktops 7.15 LTSR CU7 fails on Windows Server 2016 ? We have a isolated on-premise farm (no internet access) running fine with 7.15 LTSR CU6 and whatever we try, upgrading, in the default way, to CU7 fails. Patching and upgrading is a requirement due to our companies policy so all installed components are up-to-date.

We see XenDesktopServerSetup.exe running all the time and launching new processes/instances but there is absolutely no progress window so we have no idea what is happening. Even letting it run for several hours gives no positive result. Loggings apparently give no indication why the installation is unsuccessful.

Ideas of what might be causing this behaviour?

Link to comment

2 answers to this question

Recommended Posts

  • 1

Hi Henri,

 

Are all of your upgrades to Server 2016 failing? Without knowing anything about your environment it sounds like something in group policy or your security software, but that's just speculation. Also, are we just talking about the VDA or other components?

We upgraded from CU5 to CU7 without issues on Server 2016. I can only suggest disabling your security software, or possibly moving the server temporarily to an OU without group policies.

 

  • Like 1
Link to comment
  • 0

Hi Christopher,

 

Thanks for asking. This issue we had on our delivery controllers as well as on our XenApp servers. We've managed to solve it. Previous upgrades worked without any problem.

Monitoring the installation using a.o. ProcMon we found that the installation got stuck since apparently there was a registry key (RunOnce) present for the installations executable.

We've deleted that registry key as wel as, what we've found too, two sub-directories in C:\ProgramData\Citrix which we renamed (XenDesktopSetup and Storefront Install).

After this the installation worked like a charm and both directories got recreated as well as the registry key.

Case closed :)

 

Regards, Henri

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...