Jump to content
Welcome to our new Citrix community!
  • 0

Published Desktop not appearing in Storefront


Question

Hi, we have a Citrix Virtual Apps and Desktops 7 deployment (1912).

 

I have published several apps successfully on this deployment.

 

I now need to publish one of our server desktops for some administrators. I am still relatively new to the VAD environment, I was used to XenApp 6.5 before and there it was quite easy to publish a server desktop. In the new environment, I followed instructions I could find in the Citrix forums and documentation and I have created a Delivery Group with the Desktop I want to publish (multi-session OS). I have assigned the relevant users and all seems fine, but when I log into Storefront with a user that has access to the Desktop, the Desktop doesn't appear -  I only see the Apps I have published before.

 

I'm not sure what I'm doing wrong and would appreciate any pointers or advice. If someone can point me to a proper tutorial specifically for Desktops somewhere it would also help a lot.

 

Many thanks in advance!

 

 

Link to comment

4 answers to this question

Recommended Posts

  • 0

I found the problem! It was a simple setting in the Storefront configuration that hid the Desktops

 

Go to  Stores > MyStore > Manage Receiver for Web Sites > Configure > Client Interface Settings: the dropdown list "Application and Desktops view on Receiver for Web" was set to show Applications only. After changing it to show both views, I was able to find and launch my Desktop.

 

Hope this can help someone else in future!

clientinterfacesettings.png

  • Like 1
Link to comment
  • 0

It sometimes takes a few minutes for new items to appear, and sometimes signing out and back in to the Storefront page or Workspace app helps too.    But I guess you've probably left it long enough now.

 

In the Storefront page (or in the Workspace app) on the black bar at the top, are you looking at Home, or Desktops?   Many times I have users say they can't see it, and it's just because they haven't used it before so it only sits in Desktops.

Link to comment
  • 0
7 hours ago, Michael Burnstead1709159565 said:

It sometimes takes a few minutes for new items to appear, and sometimes signing out and back in to the Storefront page or Workspace app helps too.    But I guess you've probably left it long enough now.

 

In the Storefront page (or in the Workspace app) on the black bar at the top, are you looking at Home, or Desktops?   Many times I have users say they can't see it, and it's just because they haven't used it before so it only sits in Desktops.

Thanks very much for the response Michael! There is no "Desktops" icon in Storefront, it only shows Home and Apps. Please see screenshot attached.

SFscreenshot.png

Link to comment
  • 0
On 7/20/2021 at 12:26 PM, Walter Backeberg1709162865 said:

I found the problem! It was a simple setting in the Storefront configuration that hid the Desktops

 

Go to  Stores > MyStore > Manage Receiver for Web Sites > Configure > Client Interface Settings: the dropdown list "Application and Desktops view on Receiver for Web" was set to show Applications only. After changing it to show both views, I was able to find and launch my Desktop.

 

Hope this can help someone else in future!

clientinterfacesettings.png

 

 

I have published an MCS desktop (static) and it does not show up even after 20 hours. The settings are as shown in your file. I just created this yesterday. 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...