Jump to content
Welcome to our new Citrix community!
  • 0

How do I use a PC keyboard via Receiver/Mac on Windows 10 VM, and have IntelliJ shortcuts working?


Martin Erzberger

Question

Simple and common IntelliJ / Windows shortcuts do not work, such as Ctrl-Space for code completion. This will be intercepted by the Mac and execute a keyboard layout switch instead.

Actually almost none of the usual shortcuts work because of the Mac/PC mixup.

 

I also tried to load the Mac keyboard shortcuts into IntelliJ / Windows and use a Mac keyboard, but this is even worse: Almost all shortcuts use the command key on a real Mac, which is not sent to IntelliJ in Windows.

 

So: How can I work with IntelliJ, given that I have to use a Mac for the Citrix receiver?

 

There should be a way (in full screen mode) to completely ignore / circumvent the Mac and send all keystrokes directly to the VM, including the Windows/Start key. Hypervisors such as Parallels can do this ("optimised for gaming"), so it should be possible for Citrix as well. I would not mind to define some sort of "hot key" to exit this mode, which is what hypervisors do.

While we are on the subject: Also the mouse must be captured in this mode, and the Mac menu from the top or the Dock from the bottom must not show up at all.

 

Am I missing something, or is this really not possible?

Link to comment

1 answer to this question

Recommended Posts

  • 0

I have working the setup you describe. I use IntelliJ for Windows. In Citrix Workspace, I have selected the option to use left Command for Ctrl (and left Command + Option for Alt) in the VM. Code completion works for me. I press Command + Space and it see the code completion menu in IntelliJ.

 

I disabled or remapped any Mac system commands that use Command + Space since the Mac will take precedence and intercept that key combo, as you saw. I don't change keyboard layout on my Mac often enough to warrant a global shortcut like Command + Space, so I just disabled it. I'm not sure if that's a good solution for you too.

 

Hope  that helps.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...