Jump to content
Welcome to our new Citrix community!
  • 0

WSL/Ubuntu and AppLayering


Question

Hi,

 

We're looking to install WSL and Ubuntu on our VDIs and I'm running into issues. I was wanting to check if anyone has successfully got this working?

 

Our environment:

  • AppLayering with PVS.
  • The layers have internet access but the VDIs don't.
  • FSLogix is used for profile management.

 

My understanding is that Windows apps are installed per user so I can't install this whilst editing the app layer.

I've tried installing under my user account whilst logged in to the VDI 'Add-AppxPackage C:\Ubuntu\Ubuntu2004.appx" and then launching the app however this seems to corrupt the install as I can't create a new Linux user.

 

image.thumb.png.0d3893d4f01c4858cc2ae1214a2b217a.png

 

 

image.png

 

 

If I run the same "Add-AppxPackage C:\Ubuntu\Ubuntu2004.appx" on a standard Windows 10 VM, Ubuntu installs ok and there are no errors.

 

Thanks.

Edited by Anay Tejura
Link to comment

8 answers to this question

Recommended Posts

  • 0

I've tried using WSL and WSL2. 

I saw another comment on the forum that WSL2 won't work so recently have used WSL only.

 

The steps I used;

  1. Enabled WSL on OS layer: dism.exe /online /enable-feature /featurename:Microsoft-Windows-Subsystem-Linux /all /norestart
  2. Restart OS layer
  3. Download .appx package from Manually download Windows Subsystem for Linux (WSL) Distros | Microsoft Docs
  4. Install package: Add-AppxProvisionedPackage -Online -PackagePath C:\Ubuntu.appx -SkipLicense
  5. Publish new vdisk and try to open app as a domain user.

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...